Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

General Problem: Server load 20.92 (8 CPUs) [it varies from 7 to 40, normally it should be less than 1)

Server Specs: Dedicated Server Intel Core i7 (8 Cpus) RAM: 8GB We use WHM and we have about 25 databases (8 are wordpress) most of which are MyISAM. We are using the default MySQL options as always.

Now WHM won't allow us to downgrade to mysql 5.1 When we disable mysql, cpu goes down to 0.20 (8 CPUs)

As i said, the problem is CPU gets over 100%.

Now when i look at PhpMyAdmin Statistics: "Query statistics: Since its startup, 387,979 queries have been sent to the server" And the server was running for 20 minutes.

show status like '%onn%'; prints this:

| Aborted_connects         | 1     |
| Connections              | 93576 | (and growing by ~100 per second)
| Max_used_connections     | 46    |
| Threads_connected        | 7     |

7 rows in set (0.00 sec) When i shut down apache2 no new connections are made.

/etc/my.cnf

[mysqld]
log-slow-queries
default-storage-engine=MyISAM
max_connections=500
innodb_file_per_table=1
thread_concurrency=16
wait_timeout=120
share|improve this question
    
Have you considered that maybe some external program might do weird queries. I rember I had a stuck process of ido2db (from Icinga monitoring) doing nothing but logging in, doing one setting and then logging off ... about 1000 times per second. –  Christopher Perrin Jul 8 '12 at 17:17
    
Switch to InnoDB, see what happens –  Joel E Salas Jul 8 '12 at 18:40
    
Thank you for your answer womble. I have already mentioned what the General Problem is. But either, u don't get it, or u dont get it. –  Byivan Jul 8 '12 at 20:55
1  
"We are using the default MySQL options as always." ... are you sure you don't see a problem here? MySQL default options are made for your grandma's 386. –  Janne Pikkarainen Jul 9 '12 at 9:55
    
Thank you Jannie, your solution almost worked. –  Byivan Jul 9 '12 at 13:31

1 Answer 1

Try this command: sudo date `date +"%m%d%H%M%C%y.%S"

See the following blog post about that problem.

http://blog.mozilla.org/it/2012/06/30/mysql-and-the-leap-second-high-cpu-and-the-fix/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.