Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting an error trying to run the webserver connector configuration tool for coldfusion 9 on centos 5x + apache 2...

here is the error:

/opt/coldfusion9/runtime/lib/wsconfig/1/build_jrun22
/usr/share/build-1/libtool --silent --mode=compile gcc -prefer-pic   -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include   -I/usr/include  -w  -c -o /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.lo /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.c && touch /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.slo
sh: /usr/share/build-1/libtool: No such file or directory
apxs:Error: Command failed with rc=8323072

this is the script itself:

#!/bin/sh -e
#
# To build Apache module jrun22 for JRun/ColdFusion
#
/usr/sbin/apxs -c  -Wc,-w -n jrun22 /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/jrun_maptable_impl.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/jrun_mutex.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/jrun_property.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/jrun_proxy.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/jrun_session.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/jrun_utils.c \
/opt/coldfusion9/runtime/lib/wsconfig/1/platform.c
/usr/sbin/apxs -i -S LIBEXECDIR=/opt/coldfusion9/runtime/lib/wsconfig/1/ -n jrun22 /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.la
strip /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.so

So obviously it's complaining about not being able to find libtool, its not in /usr/share/build-1/ it's in user/share...

So how do I tell apxs or libtool the correct path?? the man pages for apxs don't seem to indicate any option....

share|improve this question
    
Do you need to use jrun, or can you use a less horrible servlet engine? –  Shane Madden Jul 8 '12 at 18:36
    
yes I do need to use jrun. Do you have any thoughts on how to solve the problem above? It looks like a problem with a path or environment variable or something to do with libtool - I just don't know. –  Sean Kimball Jul 8 '12 at 18:50
1  
have you tried lying to it? ln -s /usr/share/libtool /usr/share/build-1/libtool –  drumkiller Jul 11 '12 at 18:51
    
@drumkiller - yes that's exactly what I did, worked just fine. –  Sean Kimball Jul 11 '12 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.