Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Percona mySQL on my fresh CPanel server (no databases yet) according to: http://www.ecommy.com/linux/install-...el-environment

Everything seemed to be OK and the server also starts fine, except some commands return this error:

root@server [/var/lib/mysql]# mysql -A -sN information_schema -e
"select * from user_statistics;"
mysql: unknown variable 'innodb_file_per_table=1'

root@server [/var/lib/mysql]# mysql -A
mysql: unknown variable 'innodb_file_per_table=1'

In my /etc/my.cnf I have:

[mysql]
innodb_file_per_table=1
userstat_running=1

I am planning on using InnoDB for the databases.

Anyone know what the problem is? Or even better, how to fix it?

I have installed Percona 5.5 with yum on CentOS.

share|improve this question

closed as off-topic by HopelessN00b, Ward, Jenny D, bangal, Tim Brigham Feb 22 at 19:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

innodb_file_per_table

That setting goes in the [mysqld] section not the [mysql] section in the /etc/my.cnf. If you move it to the correct section that issue will go away

share|improve this answer
    
I tried that, but when I change mysql to mysqld, the server doesn't start. – user1227914 Jul 8 '12 at 21:29
    
He didn't say rename the section, he said move the variable to the correct section. – Ben Lessani - Sonassi Jul 9 '12 at 7:44

Use innodb_file_per_table in the following way under [mysqld] section in my.cnf

[mysqld]
innodb_file_per_table
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.