Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I configured munin-server and munin-node on same box and everything works fine. it is a fantastic monitoring tool.

Now situation got complicated because I've to add a node which is located in another country. Both server and node have dynamic IP's but with dyndns domain configured.

I know I need to define IP of server in node config and IP of node in server config. But since I'm dynamic in both places will munin configuration file take domain instead?

Any help appreciated,


share|improve this question
up vote 1 down vote accepted

For the munin-node it really doesn't matter if the IP is dynamic as long the munin-master can access it.

You just specify host * in the munin-node.conf so it will bind on every network device and make sure to change allow yourdomain\.com$ directive to your dynds domain.

For the munin.conf host group entry just use the dyndns address instead of the IP.

The solution is not ideal, because when your IP will change there is a chance that your master will still have the old DNS entry cached, which means you won't be able to fetch new data from the node. Worst case scenario you will loose few minutes of data.

share|improve this answer
I don't think allow accepts a domain ... only an IP, right @golja? See for example:… – g33kz0r Oct 18 '13 at 12:49
I tried this (munin node v2) and it didn't work. Because the "allow" option in munin-node.conf doesn't permit names - only IP addresses. PLUS - "host *" in the same file will bind to all interfaces - true BUT.... it bound using IPV6 not IPV4. (I have a DEBIAN system and IPV6 is the "out of box default") I couldn't make the "allow" option work with an IPV6 bind. I did try the "allow_cidr" option - didn't want to work with the IPV6 bind either. If I specify the bind to (for example) - then the bind is IPV4. Then I was able to use "allow_cidr". – user236691 Aug 8 '14 at 6:14
As those values are directly passed to Perl's Net::Server, in order to use hostnames in the allow directive, you must also enable reverse_lookups. Check – Diego Feb 26 '15 at 14:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.