Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My backups are failing when I try to use a network share hosted by a Synology DS211 disk station. They work fine if I target a different network share (i.e. \server1\data\larry).

When I run the following command:

Wbadmin start backup -backupTarget:\\diskstation\backup-larry -include:C:

This is what I get:

wbadmin 1.0 - Backup command-line tool
(C) Copyright 2004 Microsoft Corp.


Note: The backed up data cannot be securely protected at this destination.
Backups stored on a remote shared folder might be accessible by other
people on the network. You should only save your backups to a location
where you trust the other users who have access to the location or on a
network that has additional security precautions in place.

Retrieving volume information...
This will back up volume WIN7(C:) to \\diskstation\backup-larry.
Do you want to start the backup operation?
[Y] Yes [N] No y

Note:  The list of volumes included for backup does not include all the
volumes that contain operating system components. This backup cannot be used
to perform a system recovery. However, you can recover other items if the
destination media type supports it.

The backup operation to \\diskstation\backup-larry is starting.
Creating a shadow copy of the volumes specified for backup...
Creating a shadow copy of the volumes specified for backup...
The backup operation stopped before completing.
Summary of the backup operation:
------------------

The backup operation stopped before completing.
Detailed error: Access is denied.
Windows Backup failed to write the file: '<backup location>\WindowsImageBackup\<Computer Name>\MediaId'.
Access is denied.

The backup creates the following path \\diskstation\backup-larry\WindowsImageBackup\LARRY-MYDOMAIN\ but its empty.

I definitely have read/write access on the target directory (\diskstation\backup-larry). I have verified this by looking at the permission and by actually copying files to this location.

Any suggestions?

share|improve this question
    
Thanks for the suggestions so far. I'm certain that Wbadmin is running as the correct user. I've tried passing my credentials on the the command line and I've tried other locations that only I have access to. Both work if the network share is not on the the Synology disk station. –  Larry Jul 11 '12 at 4:00

5 Answers 5

Have you tried specifying your username / password combination for accessing this share?

Wbadmin start backup -user:<username> -password:<password> -backupTarget:\\diskstation\backup-larry -include:C:
share|improve this answer

Wbadmin might be running under a local system account which can't access the remote share on the Synology box. you might need to map a network drive for it to write to and specify the username and password to avoid this. (or run the backup under a different service account)

share|improve this answer
up vote 0 down vote accepted

I created an iSCSI target and used that for my backups. I'm still not sure why my original approach did not work.

share|improve this answer

Create a VHD via Disk Management in windows

locate the location of the new VHD in the location you need to backup into.

check mark on make the VHD expandable to increase the performance

After creating the VHD its attached to your windows and will act as a normal harddisk you can specify the backup to

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.