Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My linux servers are not showing their newly resized fibre Luns after being extended on the fly(online).the storage guys have successfully resized the LUNS from 1Tb to 2 Tb .We are running fibre SAN ((on HP EVA kit,PSV450) not ISCSI LUNS on RHEL 5.3 Linux machines. I have done the following below but unsuccessful, I still cannot see the new size of 2Tb , i still see the old size of 1Tb.Please note that these LUNS are configured as raw devices for oracle and hence no LVMs are used .Have i missed any procedure

Rescan scsi bus

echo 1 > /sys/block/sda/device/rescan
echo 1 > /sys/block/sdb/device/rescan

Update Size of your multipath device

multipathd -k"resize map orac_backup"
resize2fs /dev/mapper/orac_backup

(seems to fail probably a procedure not needed in this scenario)

I alo tried this to test multipath failover by running]

multipathd -k
del path sda 
add path sda
del path sdb 
add path sdb

All commands run successfully but still old LUN size is showing, the Linux OS or kernel still doesnt see the new Lun size.I have tried several times and also restarted multipath service in between each procedure numbered(listed) above, but still unsuccessful.Please help, any help would be greatly appreciated.

Kind Regards D

share|improve this question
    
Are you using LVM on this? what file system? –  Chopper3 Jul 10 '12 at 12:31
    
Thanks for the reply , but as i mentioned i am not using LVMs and these are raw devices not file systems –  Dominiqs Jul 10 '12 at 13:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.