Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running XenServer on an Dell R610 and am running into a catch-22. During install from DVD, CentOS can't find the DVD package catalogue. It's a reported error for some, XenServer + CentOS6 + DVD install in some hardware configurations = failed install. Yes, I checked the MD5 and let the disc test pass. In every reported case, the netinstall was the solution.

The issue is my net access is required to go through a web proxy that prompts before you can download a file. This naturally breaks any download automation. I've been waiting on our IT to put in an exception rule to allow my lab to bypass the prompt, but it's been over 3 weeks now and they don't seem responsive. (I've been working on this a day or two a week)

I want to try and host the netinstall files local in my Xen network. Right now I only have a bunch of Windows based VMs, CentOS won't install so I don't have any Linux tools.

I had tried simply hosting all the DVD contents off one of the Windows servers using Mongoose. (I didn't want to setup IIS) I copied them to a hosted sub-directory similar to all the mirrors out there (e.g. http:///centos/6.2/os/i386/) with no auth or anything. Then in the netinstall I correctly pointed to it.

I now realize just copying the DVD files over won't work. The repodata will point to a local device, not the site I'm hosting. (e.g. the DVD repodata includes xml that points to where the packages are) Clearly I'm hosting them over HTTP, not from a DVD.

Is there an easy way to sort this out? I'm just trying to install CentOS6 on Xen. If there's a turnkey downloadable Xen image with CentOS 6.2 on it, or a downloadable repo image, I'll take that too!

Thank you in advance!

share|improve this question

The CentOS Wiki has a lengthy explanation of how to set up a local mirror. In short, you start with a copy of the DVD and then fill in the gaps using rsync against another mirror.

share|improve this answer
From CentOS. I'm having trouble installing it in my environment altogether. – garlicman Jul 11 '12 at 21:19
In that case, it seems you have two separate questions. – Michael Hampton Jul 12 '12 at 0:33
I don't think so. I stated that I was having a hard time getting CentOS installed in my network, (because the netinstall had to go through a damned prompting web proxy, and the DVD wouldn't fail) and that I was trying to host the CentOS DVD files from Windows (which installed fine on XenServer from DVD) for local netinstall mirror. The CentOS docs explain how to setup a local mirror from a mirror (that I can't reach without going through the prompting Web proxy) using scripts that will only work on a CentOS install I don't have. – garlicman Jul 12 '12 at 17:18
Thanks for the help and follow up though. I don't want to sound ungrateful. – garlicman Jul 12 '12 at 17:18

If you take a look at the index of a mirror such as you just need to recreate this structure and contents inside the path you are sharing via Mongoose. You can use the files directly from the DVD, even as Linux symlinks or NTFS junction points if the web server software permits, except for the repodata folder which you must download directly from the mirror. Then, you can point your CentOS netinstall to "http://your.mongoose.server/" assuming that 6.2/os/i386 folder structure is mirrored in its root. You should see Anaconda first download images/install.img and you should be good to go.

share|improve this answer
You're the closest. I didn't have to recreate it so much as copy the contents of the CentOS 6.2 DVD to a Mongoose hosted ./centos/6.2/os/i386, THEN I had to rename all of the /repodata/ MD5 sum named files with file extensions that matched what was in the /repodata/repomd.xml file. In the DVD, the base file references, like repodata/9b02...27e-other.sqlite.bz2, where without file extension. e.g. repodata/9b02...27e Once I did that, the netinstall would pull down the catalogue properly. – garlicman Jul 11 '12 at 21:23

Repodata is relative by default. It's actually more work to force it to point to a specific directory than to let it be relative.

share|improve this answer
That might be true but you're assuming the /repodata/repomd.xml is the same in the DVD as on a mirror. It's not. I have the DVD, and our webproxy's download prompts make sucking an entire mirror down impossible. – garlicman Jul 11 '12 at 21:20
Have you considered pulling down a new repomd.xml? – Ignacio Vazquez-Abrams Jul 11 '12 at 21:44
I tried that and it didn't work. I also tried manually downloading all the mirror /repodata/ contents and trying to host that as well. At the time I wasn't sure what the problem was. It's possible that the netinstaller always uses the initially loaded repomd.xml, and so if you change anything and retry, it's still using the old one. (something I suspected) – garlicman Jul 12 '12 at 17:14
up vote 0 down vote accepted

Ok, I'm going to answer this myself because I got it working locally from the DVD itself which is what I was looking to do. Hopefully this helps someone else.

As suggested here by Dell_JonathanS (you get a +1 from me) if you can download the contents of a mirror directly, its easiest. Just rip the files and structure from* down to a locally hosted HTTP directory. You don't have to host the full mirror path. In the CentOS netinstall you can specify any URL.

If you can't download from a mirror and you have the install DVD, copy the files and structure to a locally hosted HTTP directory. Then go into /repomod/ and open repomd.xml. Notice that the of primary_db is to a file with an extension, while the files in /repomod/ are without extension.

<data type="primary_db">
     <location href="repodata/48da39...46d6-primary.sqlite.bz2"/>

Go look for that file in the /repomod/ directory. You'll notice it doesn't have the same extension. Rename that file to include the extension. Repeat this for all the other repomd.xml identified. Go ahead and start the netinstall pointing to the modified locally hosted CentOS DVD files.

Note that I consider this a hack, but if you can't download from a mirror itself for whatever reason, this worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.