Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm struggling to set up tomcat 6. I'm using openSuse 12.1. I installed it from standard repositories with zypper. It then said that it couldn't find configuration file, so I created an empty /etc/java/java.conf, required by /usr/share/java-utils/java-functions shell script.

After that tomcat seems to start normally with service tomcat6 start (no error messages at lest), but there is nothing on localhost:8080 (standard "Oops!" of chrome).

If I check service tomcat6 status, I get :

tomcat6.service - LSB: Tomcat Servlet Container
  Loaded: loaded (/etc/init.d/tomcat6)
  Active: active (exited) since Tue, 10 Jul 2012 18:06:12 +0300; 3s ago
 Process: 3831 ExecStop=/etc/init.d/tomcat6 stop (code=exited, status=0/SUCCESS)
 Process: 3918 ExecStart=/etc/init.d/tomcat6 start (code=exited, status=0/SUCCESS)
  CGroup: name=systemd:/system/tomcat6.service

(why is it exited?). Also, the catalina.out log looks okay :

Jul 10, 2012 6:06:13 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
Jul 10, 2012 6:06:13 PM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
Jul 10, 2012 6:06:13 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jul 10, 2012 6:06:13 PM org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
Jul 10, 2012 6:06:13 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 549 ms
Jul 10, 2012 6:06:13 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jul 10, 2012 6:06:13 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.33
Jul 10, 2012 6:06:13 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jul 10, 2012 6:06:13 PM org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
Jul 10, 2012 6:06:13 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 91 ms

I don't know what tools I can use to detect the problem. I would greatly appreciate some help.

share|improve this question
    
try l27.0.0.1:8080 ... an "netstat -na" output would be useful. –  h3xStream Jul 12 '12 at 2:30
    
127.0.0.1:8080 was the same and netstat -na didn't have 8080 in it. Although I already gave up on tomcat and successfully installed glassfish, so I guess it doesn't really matter, unless someone else may have this problem. –  Karolis Juodelė Jul 12 '12 at 7:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.