Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have couple of debian boxes at the office where we have a dns server, so ftp'ing to these boxes from a windows machine using a .net application is fairly faster and we had no issues. As closer we get to deployment of our project, we get to set up a test environment where we connect these windows boxes and debian boxes via a switch and there's no dns server, all IP addresses are manually set and they are static. And we're experiencing a very peculiar problem, all ftp operations are timing out. Machines can ping each other, we have connectivity, but it's just that ftp is super slow. Just to test the situation I went into debian command line tried to ftp the machine that I am on using it's IP address(let's say machine's ip address is 16.1.X.X)

ftp 16.1.X.X

Machine instantly responds saying connected to 16.1.x.x but it takes up to 40 seconds prompting for ftp username and password.

Since I am on the machine I also tried:

ftp 127.0.0.1

it instantly asked for username and password. So it looks like it takes too long to identify 16.1.X.X since there's no dns server.

I tried running ftp -dv 16.1.X.X

Only extra information I am receiving is ftp: setsockopt: bad file descriptor.

I didn't have this problem in my office, so I am suspecting that it has something to do with DNS, any ideas will be greatly appreciated.

share|improve this question
    
Are the boxes behind some NAT or firewall configuration? or are they on the same subnet as you? –  gfountis Jul 10 '12 at 15:46
    
They are behind a firewall configuration and they are in the same subnet. –  erin c Jul 10 '12 at 15:52

2 Answers 2

up vote 1 down vote accepted

I not certain if this will help, but if you have no DNS server you should populate the /etc/hosts file on each host.

Here is an example format:

198.51.100.1    host1.example.com host1
198.51.100.2    host2.example.com host2
198.51.100.3    host3.example.com host3
share|improve this answer
    
I will try and will let you know. –  erin c Jul 10 '12 at 15:52
    
this solved my problem when I entered host ip and client ip in the debian's /etc/hosts slowness problem went away, and ftp connection started to take much less time, yet still .net application is failing with not logged in errors, then I manually logged in to the ftp on debian host and put a dummy file and everything started working fine. It is strange I really don't understand what fixed the second problem, It scares me that I have to struggle with 3-4 other debian boxes same way. –  erin c Jul 10 '12 at 18:48

Does Debian use vsftpd? If so you could disable reverse lookups with adding this to your .conf file.

reverse_lookup_enable=NO
share|improve this answer
    
I will try and will let you know. –  erin c Jul 10 '12 at 15:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.