Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting a large number of undefined references when using


I have added the "zend_extension="/bla/"" to the conf for apache and it is giving me a config test failed because it cannot find the file. The file has been chown'd to www-data, so I do not believe it is a permissions error. I have run the wizard at to make sure the version would be correct, I updated to the version it recommended with an install from source and still receive the same error with apache and same output from $ld. I originally installed xdebug with:

$apt-get install php5-xdebug

And have also tried with:

$pecl install xdebug
share|improve this question

The problem is a combination of forgetfulness, stupidity and some actual errors. When I originally installed it the zend_extension was set in the php.ino. After this didn't work I tried in in the apache configuration (which is not where this goes). After the correct version was installed the extension enabler was still in apache rather than php.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.