Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a setup with two ESXi5 servers.

We are(were) running with a ISCSi box to server disk for the VM's - however we are in the progress of migrating away from it, because the storage os disk is bad.

Now, one of the ESXi hosts has been running for ~20hrs, and it seems like the management services just crashed on that host..

The vms are still running - so it's not really serious. However, I want to fix it.

Should I be worried? Will the VM's keep running?

The hosts does respond on pings.

I am running a vcenter to administrate the hosts.

Thanks in advance.


I have now managed to get the services running:

~ # /etc/init.d/vpxa status
vpxa is running
~ # /etc/init.d/hostd status
hostd is running.

But the server is still not responding on either VMware vSphere Client nor the webinterface.

I can however use paping on both port 80 and 443 to the server, which works brilliant.

I would like some help to move on in this case.

share|improve this question
Are your servers HCL compliant? – Chopper3 Jul 11 '12 at 13:47
I would definately think so - It is Fujitsu RX300S5's. The system has been running fine for the last few years, so it is a recent issue that came up right around when the storage started to mess with us. – Frederik Nielsen Jul 11 '12 at 13:52
Im experiencing the same problem. All of my Virtual machines are running fine except my two vcenter appliances. Since my vCenter appliances and the management interface are down i cant get into the esxi host to migrate the VM's to another host. I tried restarting the managment interface but had no luck. The issue was the result of our SAN dropping a node for about 10 seconds. – user257024 Dec 4 '14 at 0:06
up vote 2 down vote accepted

Log on to the console of the server in question and restart the management agents

  • Press F2 to customize the system.
  • Log in.
  • Select "Restart Management Agents"

VMWare also details this process for ESXi 5 in this knowledgebase article.

share|improve this answer
Thats just a temporary solution I think - any idea on how to prevent it from happening? – Frederik Nielsen Jul 11 '12 at 13:57
No, it's not a temporary solution. Sometimes this happens... even in stable installations. That's why VMWare made it an option in the management interface. – ewwhite Jul 11 '12 at 14:00
Okay, will try it out when I hit the office tomorrow. – Frederik Nielsen Jul 11 '12 at 14:02
I'd consider it a step in diagnosis...if it continues to crash shortly after restarting, you may have a problem. If it seems stable after restarting, it could have been a fluke. – Bart Silverstrim Jul 11 '12 at 14:02
Could it have something to do with an underpowered vCenter server? – Frederik Nielsen Jul 11 '12 at 14:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.