Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created an ubuntu image in windows azure vm. I am trying to open port 7171 to the outside world. how can I do it?

I have tried issue the iptables command but it did not work, not sure if I did not use it correctly or there is azure level setting to set?

EDIT: maybe it is opened only on localhost and not to the world? how can I verify that?

share|improve this question
can you give us the output of iptables-save? – Zypher Jul 11 '12 at 18:32
the output is empty. tried to redirect output with > but still empty – Yaron Naveh Jul 11 '12 at 18:39
up vote 4 down vote accepted

You'll need to add it as an endpoint instead. From the Windows Azure preview portal, select Virtual Machines -> Your virtual machine. Then click the endpoints tab and finally New. You can see there that only SSH port is open by default.

share|improve this answer
How can do this in New Portal, – mesut Jan 23 at 13:12

Using Azure's new portal:

  1. Open your VM.
  2. Go to Network interfaces in the Settings window
  3. Click on your network interface
  4. In the network interface window, there is a "Network security group" section
  5. In the network security group's settings click on "Inbound security rules"
  6. Add a new rule

I'm not sure if there is a shorter way of getting there.. Next time I'll make sure to set up my ports when creating a VM.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.