Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've set up Webmin and Virtualmin on a CentOS 6 dedicated server. Postifx / Dovecot config is untouched by me, and I havent tried to open or close any ports manually.

My problem is that after creating a new virtual host and email users for that host, the new email addresses don't seem to be working.

According to nmap, ports 25 and 110 are open, and the MX record and mail.domain.com A record on my domain are all correct, but incoming email isn't getting to the inbox and I can't connect to the SMTP server using a mail client - connection gets refused on port 25. I seem to be able to log in to the POP server but none of my test emails have come through.

Any ideas on what could be wrong?

share|improve this question
    
ok... any explanation for the downvotes? am I being braindead-stupid or have I asked this question incorrectly? –  jammypeach Jul 12 '12 at 9:45
    
alrighty then. grumble bloody unconstructive downvoters grumble –  jammypeach Jul 12 '12 at 10:52
    
I think the general consensus is that Webmin and Virtualmin aren't meant for full-scale deployment as it can open up new attack surfaces, and also this could have probably been solved by reading some documentation. Don't worry about it too much. –  tombull89 Jul 12 '12 at 11:19
    
@tombull89 thanks for clarifying; I did get through most of the virtualmin / webmin docs but they are thin on the ground regarding email setup. doesnt matter, sorted now, thanks. –  jammypeach Jul 12 '12 at 13:13

1 Answer 1

up vote 2 down vote accepted

Turns out my problem was solved by a couple of relatively simple measures:

first, I enabled the submission and smtps services via servers -> postfix -> server processes; these were both disabled by default.

then, I restarted postfix and dovecot from the command line

sudo /etc/init.d/postfix restart
sudo /etc/init.d/dovecot restart

and my SMTP was suddenly magically working, and the server began accepting external mail too. This may have been required either because of my changes to the services or perhaps some config changes that were made by Virtualmin when the virtual host was created. Couldn't say for sure but it is working now. Keeping an eye on /var/log/maillog in any case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.