Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a fresh installation of Hudson, default directories and all that. I have been following This Guide

I have followed what it said, up to the actual 000-default modification. I'm sort of stuck on this part.

This is what I have as my 000-default file:

<VirtualHost *:80>
    DocumentRoot /var/www
    ServerName name
    ServerAlias name
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
    </Directory>

    Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

ProxyPass /var/lib/hudson/  http://mydomain:8080/hudson/
ProxyPassReverse /var/lib/hudson/ http://mydomain:8080/hudson/
</VirtualHost>

My proxy.conf looks like:

<Proxy *>
    Order deny,allow
    Allow from all
    Allow from [mynetwork]
</Proxy>

As the guide says, I would like to access hudson by navigating to mydomain/hudson

instead of mydomain:8080/

so far, I have changed it so that mydomain:8080/ results in a 404,

mydomain:8080/hudson actually takes me to hudson

but mydomain/hudson results in an apache error that says:

 File does not exist: /etc/apache2/var

What am I doing wrong?

Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You will want to change your ProxyPass and ProxyPassReverse lines to something like:

ProxyPass /hudson/  http://mydomain:8080/hudson/
ProxyPassReverse /hudson/ http://mydomain:8080/hudson/

Here's the Apache documentation:

http://httpd.apache.org/docs/2.2/mod/mod_proxy.html#proxypass

share|improve this answer
    
It ended up being that I had to restart my server, I was restarting hudson and apache, but aparently the whole thing needed to be restarted. Now, when I go to mydomain/hudson, it re-directs me to mydomain:8080/hudson, so that works. Thanks! –  Ryan Jul 12 '12 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.