Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Windows 2008 Server and Windows Seven on ESXi using pfSense to have a NAT Network.

I just set up Active Directory and DNS in Windows 2008, I tried to add UPN to my configuration, but when I try to RDP connect using @myupn it's not working.

Normal RDP login is working using DOMAIN\User, but not user@myupn.

Does anyone have any ideas?

share|improve this question

1 Answer 1

In Windows server 2008, it is technically possible for you to specify different values for the UPN and the NetBIOS username. Check the UPN and see what you get. Ensure it is correct (and set), and see what you get.

You can specify a UPN a number of ways, also. You can specify user@subdomain, user@subdomain.domain, and user@subdomain.domain.tld. For instance, if you have a domain registered to your organization example.com, your domain's NetBIOS name would be EXAMPLE by default; some organizations may configure it EXAMPLECOM. You would normally specify, in this case, EXAMPLECOM\username but also username@example.com.

It may also be that your RDP target cannot contact the DC, so it can't resolve the UPN, but if it has cached credentials for the NB username, it will still take that.

share|improve this answer
    
I double checked my UPN and it seems legit to me, I still can't connect using user@domain.com while DOMAIN\user works –  Tempy Jul 12 '12 at 15:47
    
I wonder if for some reason the RDP target can't contact your DC, and is trying to use cached credentials? If so, it is not able to map the UPN to the cached credentials or SID locally, and needs to contact the DC for this. –  Falcon Momot Jul 12 '12 at 15:52
    
I tried to reboot and still not working, when i try to ping mydomain.com it's not working –  Tempy Jul 12 '12 at 15:54
1  
@Tempy Sounds like you have a connectivity problem. –  MDMarra Jul 12 '12 at 15:57
    
Indeed. I added the last paragraph to address this. If you can't ping mydomain.com, that is exactly what is happening. –  Falcon Momot Jul 12 '12 at 16:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.