Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running a Windows 2008 Server and after having Cablevision switch us over to a static IP my server cannot resolve certain names, namely mws.amazonservices.co.uk, mws.amazonservices.com, and smtp.gmail.com. The odd behavior here is on my machine I can resolve them fine. I have a ASP.NET application that when I run it on my machine as localhost it runs fine, once upload on the server I can't access those names. This is truly puzzling because I don't know how to even start troubleshooting this.

share|improve this question
    
Try adding 8.8.8.8 as your secondary DNS on the server. –  George Jul 12 '12 at 15:31
    
@George how do I do that? –  Joe Tyman Jul 12 '12 at 15:33
    
What are your DNS settings on the server? Open up a CMD prompt and run, "ipconfig /all" to see them all. –  silmaril8n Jul 12 '12 at 15:46
    
When did you do the cutover to static? –  tony roth Jul 12 '12 at 16:20
1  
@JoeTyman Go to control panel, under network and internet, select network sharing, click on change adapter settings, select the proper NIC, choose properties, IP4 and add to secondary DNS 8.8.8.8 –  George Jul 12 '12 at 16:26

1 Answer 1

I changed my my DNS from 127.0.0.1 to 8.8.8.8 and 8.8.4.4 per @George's suggestion. It works and everything runs much faster.

share|improve this answer
    
Good! Glad it worked! –  George Jul 12 '12 at 18:06
    
Machines should always either point to themselves (if a DNS server) or a local DNS server (if a workstation), not public DNS. You should make the changes to the DNS section on the server, and add those DNS entries as forwarders. If this is an Active Directory network, expect issues with the config you just setup. –  DanBig Jul 12 '12 at 18:44
    
Totally agree with DanBig. If nothing else, this is a massive security hole. Just google "DNS command and control". –  Simon Catlin Jul 13 '12 at 12:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.