Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

after several hours of googling and trying (and reading several posts on this page) I still do not know what I am doing wrong. So I would be very happy, if somebody could help me here...

I updated Ubuntu 11.10 to 12.4 LTS and thus had to switch vom gitosis to gitolite (the update removed the deprecated gitosis package; gitosis worked nicely before). I disabled the old gitosis installation (user gitosis) by removing the authorized_keys and the post update hook and then follwed this tutorial to install gitolite: http://cisight.com/how-to-setup-git-server-using-gitolite-in-ubuntu-11-10-oneiric/

Everything up to (including) the following line worked fine:

gl-setup /temp/gitadmin.pub

However, when I try to clone (on the same computer with my personal user which has the private key to gitadmin.pub), I am asked to enter the password of "git". However, git has no password (I created a new git user as follows:

sudo adduser --system --shell /bin/sh --gecos 'git version control' --group --disabled-password --home /home/git git

)

Can anybody help me and tell me what I am missing here!? Thanks!

PS: Git clone from a public github repo works (git was setup up with gitosis some time ago)

share|improve this question
    
Are you using a config file to reference the private key? See stackoverflow.com/questions/922210/… –  VonC Jul 12 '12 at 20:05
    
As far as I understand this post, the config file is a client thing? I also tried from a windows client (the same way it worked with the gitosis installation) - but this did not work either. I think it is something with the server setup??? –  vitr Jul 13 '12 at 7:08
    
config is a ssh file, put in the ~/.ssh directory in order to specify where the private ssh key is. It also works on Windows, provided you defined first the %HOME% environment variable. To further debug your issue, you should edit your question with the result of ssh -vvv user@server. This is first and foremost an ssh issue, but check if your gitoliteadmin.pub is registered on the server side in ~/.ssh/authorized_keys. –  VonC Jul 13 '12 at 7:20

1 Answer 1

i think you have to change your sshd_config file:

PasswordAuthentication no

or add

Match User yourUser

     PasswordAuthentication no
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.