Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed chef , which uses couchdb. It worked fine until i've secured couchdb by creating an admin user in couchdb giving and setting require_valid_user = true in default.ini as written here: http://guide.couchdb.org/draft/security.html

Now i get a 401 Network error: Connection refused, most probably because of the newly created user.

Any idea where i can set the new admin username /password for chef to access the couchdb?

share|improve this question
add comment

1 Answer

Oldie but goodie, answering for completeness sake, as it's still a valid question.

When specifying a user/pass in the couchdb config, you mush now provide those credentials to Chef Server, in the form of changing the couchdb_url parameter in the server's config file /etc/chef/server.rb, as per the source here.

This may look like:

couchdb_url "http://<username>:<password>@localhost:5984"

You must restart the Server services for this to take effect.

NOTE: Chef 11 has since been released, and CouchDB is no longer used in this version.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.