Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am going to install the first Exchange 2010 CAS role on a Windows Server 2008 R2 server. At the following link I can read a comment where it is said that installation requires Net TPC Port Sharing service to be set to automatic start, and I can find the same on many other sites, but I can't find this on Technet. So, this is required or not?

http://technet.microsoft.com/en-us/library/bb691354.aspx

share|improve this question

1 Answer 1

up vote 1 down vote accepted

While that KB article doesn't specifically mention it for R2 (only 2008 regular), this link says the setup will fail:

http://www.itsolutionskb.com/2009/11/the-start-mode-for-the-net-tcp-port-sharing-service-must-be-set-to-automatic-before-setup-can-continue-exchange-2010/

I am running Exchange 2010 on 2008 R2 and it has Net.TCP Port Sharing Service set to Automatic. I don't remember the install at this point though to guarantee I got the error, but I'm guessing so.

share|improve this answer
    
Running Exchange 2010 SP1 setup on 2008 R2 with Net.TCP Port Sharing Service startup set to Manual does not result in a prerequisite check failure. Maybe SP1 solves this issue? –  Danilo Brambilla Jul 16 '12 at 10:26
1  
Apparently SP1 simply changes it for you during setup: "When installing Exchange Server 2010 SP1, the setup application also changes the settings of the Net.TCP port sharing service from manual to automatic, something which most of us always forget to change up front when installing Exchange Server 2010 RTM." –  TheCleaner Jul 16 '12 at 13:26
    
As soon I complete the first CAS installation I'll be back to report about service startup configuration. –  Danilo Brambilla Jul 16 '12 at 14:39
1  
Just completed Exchange installation and upgrade to SP2 RU 4. Net TCP Port Sharing service is now set to automatic –  Danilo Brambilla Sep 5 '12 at 12:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.