Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've set up (well, attempted to) Apache VHosting on my VPS. But I get the following error when I try to load any site from it now:

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

This is the config file which I added:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName  photography.web.co.uk

        # Indexes + Directory Root.
        DirectoryIndex index.html
        DocumentRoot /var/www/web.co.uk/htdocs/photography

        # CGI Directory
        ScriptAlias /cgi-bin/ /var/www/web.co.uk/cgi-bin/
        <Location /cgi-bin>
                Options +ExecCGI
        </Location>


        # Logfiles
        ErrorLog  /var/www/web.co.uk/logs/error.log
        CustomLog /var/www/web.co.uk/logs/access.log combined
</VirtualHost>

Is anyone able to identify what I have done wrong? There seem to be a couple of other people who had similar problems, but I really don't follow what the solution is saying.

Many thanks!

share|improve this question
    
Could you add the output of sudo netstat -tlnp to your question? –  Ladadadada Jul 13 '12 at 11:48

1 Answer 1

up vote 1 down vote accepted
<Location /cgi-bin>
   Options +ExecCGI
</Location>

Get rid of this; it is unnecessary and should never be set in a Location anyway.

share|improve this answer
    
Thank you adaptr! So does the cgi-bin folder default to somewhere else then? Not that I'm using it right now, but were I to, I suppose it would be good to know where it's located! –  penguin Jul 16 '12 at 22:59
    
This is what ScriptAlias does. Please read the section of the manual regairding ScriptAlias for a full explanation. –  adaptr Jul 18 '12 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.