Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having trouble configuring Roundcube with SMTP authentification on Postfix. All the credentials are true, because I have no problem using the e-mail from Thunderbird and my mobile phone e-mail client. Here is the SMTP configuration for Roundcube:

$rcmail_config['smtp_server'] = 'tls://mx.cyssea.com';
$rcmail_config['smtp_port'] = 587;
$rcmail_config['smtp_user'] = '%u';
$rcmail_config['smtp_pass'] = '%p';
$rcmail_config['smtp_auth_type'] = '';
$rcmail_config['smtp_auth_cid'] = null;
$rcmail_config['smtp_auth_pw'] = null;
$rcmail_config['smtp_helo_host'] = '';
$rcmail_config['smtp_timeout'] = 0;

When I try to send an email from roundcube, I get the following error:

[12-Jul-2012 16:33:35 +0300]: SMTP Error: SMTP error: Authentication failure: No supported authentication methods (Code: ) in /usr/share/roundcube/program/include/main.inc on line 1745 (POST /roundcube/?_unlock=loading1342100016360&_lang=en?_task=mail&_action=send)

Even though the SASL authentification module for PHP is installed.

The communication between the mail server and Roundcube goes like this:

[12-Jul-2012 20:00:47 +0300]: Recv: 220 mx.cyssea.com ESMTP Postfix (Ubuntu) 
[12-Jul-2012 20:00:47 +0300]: Send: EHLO 192.168.12.18
[12-Jul-2012 20:00:47 +0300]: Recv: 250-mx.cyssea.com 
[12-Jul-2012 20:00:47 +0300]: Recv: 250-PIPELINING
[12-Jul-2012 20:00:47 +0300]: Recv: 250-SIZE 10240000
[12-Jul-2012 20:00:47 +0300]: Recv: 250-ETRN
[12-Jul-2012 20:00:47 +0300]: Recv: 250-STARTTLS
[12-Jul-2012 20:00:47 +0300]: Recv: 250-AUTH CRAM-MD5
[12-Jul-2012 20:00:47 +0300]: Recv: 250-ENHANCEDSTATUSCODES
[12-Jul-2012 20:00:47 +0300]: Recv: 250-8BITMIME
[12-Jul-2012 20:00:47 +0300]: Recv: 250 DSN
[12-Jul-2012 20:00:47 +0300]: Send: STARTTLS
[12-Jul-2012 20:00:47 +0300]: Recv: 220 2.0.0 Ready to start TLS
[12-Jul-2012 20:00:47 +0300]: Send: EHLO 192.168.12.18
[12-Jul-2012 20:00:47 +0300]: Recv: 250-mx.cyssea.com
[12-Jul-2012 20:00:47 +0300]: Recv: 250-PIPELINING
[12-Jul-2012 20:00:47 +0300]: Recv: 250-SIZE 10240000
[12-Jul-2012 20:00:47 +0300]: Recv: 250-ETRN
[12-Jul-2012 20:00:47 +0300]: Recv: 250-AUTH CRAM-MD5
[12-Jul-2012 20:00:47 +0300]: Recv: 250-ENHANCEDSTATUSCODES
[12-Jul-2012 20:00:47 +0300]: Recv: 250-8BITMIME
[12-Jul-2012 20:00:47 +0300]: Recv: 250 DSN
[12-Jul-2012 20:00:47 +0300]: Send: RSET
[12-Jul-2012 20:00:47 +0300]: Recv: 250 2.0.0 Ok
[12-Jul-2012 20:00:47 +0300]: Send: QUIT
[12-Jul-2012 20:00:47 +0300]: Recv: 221 2.0.0 Bye

I couldn't find any information regarding such errors with SMTP authentication on Google. Does anyone know what is the reason for such a strange behaviour?

share|improve this question
    
Could you please provide version of roundcube that you are using ? –  Abhijeet Kasurde Jul 13 '12 at 16:48
    
It's the Ubuntu Server 12.04 package. Package manager says it's 0.7.1 –  Ion Jul 16 '12 at 9:48

1 Answer 1

It looks like your Roundcube installation doesn't support CRAM-MD5, which is the only mechanism offered by Postfix. I would probably just enable the PLAIN and LOGIN mechanisms and use those. You probably have a line like this in /etc/postfix/main.cf:

smtpd_sasl_security_options = noanonymous, noplaintext

Change this to read:

smtpd_sasl_security_options = noanonymous
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.