Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have fpcalc installed on Linux and when I execute the following command:

./fpcalc

I get an error saying:

./fpcalc: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./fpcalc)

I have tried googling around and I could not find a straight answer to fix this problem

I am running CentOS release 5.8 (Final) and glibc-2.5-81.el5_8.2 installed

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

CentOS 5.x is based around GLIBC version 2.5. The version of fpcalc that you have is compiled against GLIBC 2.7. You will need to compile fpcalc against the C library available for your system.

The source code seems to be available here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.