Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was given a username and a temporary password on a catalyst switch and I can't figure out how to change my password...

Upon googling, I found this but when I raise my privileges to 15 by typing enable 15 and then type

username gozulin {[1] opensesame} it says:

                 ^

%invalid input detected at '^' marker

The marker is pointed at the first character after my username.

So, how do I do it?

EDIT: now I type

username gozulin password opensesame it says:

 ^

%invalid input detected at '^' marker

EDIT 2: Success!

The system is setup for (md5) encrypted passwords so the command I had to give after was:

username gozulin secret opensesame

Thank you all for your help!

share|improve this question
    
Are you in enable/privileged mode? It doesn't sound like it. –  joeqwerty Jul 13 '12 at 21:03
    
I am now in enable/privileged mode but I'm stuck at the next step now :). I've edited my post to reflect that. –  gozu Jul 13 '12 at 21:18

2 Answers 2

up vote 5 down vote accepted

The braces and brackets are just to tell you whether the option is required or not. You need to issue the command like so:

username gozulin password 0 opensesame

The 0 is because you are using an unencrypted password on the command line (and I hope they have service password-encryption enabled!) If you know the encrypted version of your password (normally not, that tends to be used for auto configs) you would set type to 1.

share|improve this answer
    
I tried that but I get invalid input detected at '^' marker with the marker pointing to the s in username. –  gozu Jul 13 '12 at 21:55
1  
@gozu and your definatly in configuration mode? switch-name#(config) prompt? –  Zypher Jul 13 '12 at 22:03
    
@gozu Also looking at your command the 0 is REQUIRED for this to work, put the 0 between password and opensesame –  Zypher Jul 13 '12 at 22:31

[Edited to cope with your updates]

The full sequence of commands should be as follows:

enable
configure terminal
username gozulin password 0 opensesame
share|improve this answer
    
I have done that but I'm stuck at the next step now :). I've edited my post to reflect that. –  gozu Jul 13 '12 at 21:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.