Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got strange problem with ipfw on FreeBSD 8.2, the problem is when I'm trying to flush the ipfw , by the following command:

/sbin/ipfw -q -f flush


/sbin/ipfw flush and then y

My dedicated server freezes, and ISP need to hard reboot it.

Could anyone help me?

share|improve this question

Your server most likely did not freeze, it was unreachable. The default rule for ipfw is to deny everything. You can recompile the kernel with " options IPFIREWALL_DEFAULT_TO_ACCEPT" set, or add ";ipfw add allow all " to your command (or build a script that flushes and adds your rules at once).

share|improve this answer
Thats what ISP administrator did told me. I'm now in the rescue mode , and while entering the commands from the question I got the following notice: ipfw: setsockopt(IP_FW_FLUSH): Protocol not available. – Scott Jul 14 '12 at 8:05
I throwed my computer thru the window. That solved the problem, thank you. – Scott Jul 14 '12 at 8:11
Next time try to use /usr/share/examples/ipfw/ That script change rules as desired and wait for confirmation. If no confirmation occured, script treat that as lockup and rollback previous working config to unlock firewall. – Kondybas Jul 14 '12 at 18:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.