Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've forced 1775 permissions on directories with force directory mode = 1775. It works when I create a new directory however it's not working when I copy/move files. Is there any other option for this?

Regards

share|improve this question
    
Can you give some examples of what you expect and what you get? What Samba version are you using? –  ott-- Jul 14 '12 at 18:03
    
SambaBox: CentOS 6.3, samba-3.5.10-125.el6.x86_64. I'm accessing Samba server from my notebook (CIFS mount). I've set force directory mode = 1775 and when I create a directory from my notebook the permissions are as expected drwxrwsr-t (I also explicitly set GUID) however when I copy or move a directory from my notebook to a Samba share the permissions are drwxrwxr-x –  HTF Jul 14 '12 at 18:53
add comment

1 Answer 1

up vote 1 down vote accepted

The force directory mode directive only influences the creation of the directory -- it doesn't have any affect if the client then sets the mode on an existing directory. You'll probably find that the copy process first creates the directory, and then sets the mode to match the source. Try to do the copy with something which does not preserve the mode (e.g. cp without --preserve, -p or -a).

share|improve this answer
    
I've tested and it actually works correctly from the command line. It also works fine from Windows machine - so this is related to Nautilus (Ubuntu 12.04)? –  HTF Jul 15 '12 at 9:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.