Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed dovecot, postfix and roundcube on an ubuntu 12.04 box. The system is basically working - i.e it is able to send/receive mails to/from other domains. However, some domains cause the following error message in /var/log/mail.log

Jul 15 01:59:21 one postfix/smtp[2019]: 0D0399C025F: to=<someone@destdomain.com>, relay=sm01.destdomain.com[x.x.x.x]:25, delay=0.56, delays=0.4/0/0.06/0.1, dsn=5.5.2, status=bounced (host sm01.destdomain.com[x.x.x.x] said: 504 5.5.2 <contact@localhost>: Sender address rejected: need fully-qualified address (in reply to RCPT TO command))

Do you have any ideas whats wrong here? I.e. How to force postfix to use "contact@mydomain.com" instead of "contact@localhost" when connecting to an other mail server?

Any hits are appreciated. Thank you.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

$mydomain is used as a default value for many other configuration parameters, but it does not set the sender domain.

Take a look to the $myorigin parameter in /etc/postfix/main.cf

It specifies the domain that appears in mail that is posted on this machine. The default is to use the local machine name, $myhostname, which defaults to the name of the machine.

For more information, see Postfix basic configuration README

share|improve this answer
    
Thanks for the additional background information! –  Tolaksa Jul 15 '12 at 11:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.