Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I remember running this command before and it used to build all the pages, but now that I use it again it only builds the main page.

(new lines for readability)

/usr/share/awstats/tools/awstats_buildstaticpages.pl 
-update 
-config=mydomain.com 
-dir=/var/www/awstats/mydomain.com/ 
-awstatsprog=/usr/lib/cgi-bin/awstats.pl

This is my awstats.mydomain.com.conf:

LogFile="/etc/nginx/logs/mydomain.com.log"
LogFormat=1
SiteDomain="mydomain.com"
DNSLookup=0
DirData="/var/lib/awstats/mydomain.com/"
HostAliases="mydomain.com"

The only file I get is awstats.mydomain.com.html

Does anyone know what is causing this? or am I missing something else?

I'm using Debian Squeeze x86

share|improve this question
    
Why do you nulling the script output? Try to remove >/dev/null from your command and see what it returns. –  hangover Jul 18 '12 at 3:42
    
@hangover It only removes the messages of "1 files built", etc. I removed it anyway but the result is the same. –  Danny Jul 18 '12 at 3:49

1 Answer 1

up vote 3 down vote accepted
+100

It seems that awstats_buildstaticpages.pl script doesn't replace Show* config options with its default values. So in order to all statistic files could be formed, you must determine (or uncomment default) values for options in awstats config file.

These are:

ShowSummary=UVPHB
ShowMonthStats=UVPHB
ShowDaysOfMonthStats=VPHB
ShowDaysOfWeekStats=PHB
ShowHoursStats=PHB
ShowDomainsStats=PHB
ShowHostsStats=PHBL
ShowRobotsStats=HBL
ShowSessionsStats=1
ShowPagesStats=PBEX
ShowFileTypesStats=HB
ShowOSStats=1
ShowBrowsersStats=1
ShowOriginStats=PH
ShowKeyphrasesStats=1
ShowKeywordsStats=1
ShowMiscStats=a
ShowHTTPErrorsStats=1
ShowFlagLinks=""
ShowLinksOnUrl=1
share|improve this answer
    
Thank you, that did the trick, so I need to add all those setting in order to generate all the pages? The docs and even tutorials doesn't tell anything about that. –  Danny Jul 18 '12 at 5:25
    
It looks like it is. I learned this by practical, it was not described in the documentation. –  hangover Jul 18 '12 at 5:33
    
Thanks very much. It seems these values must be in the top file. If they are only in awstats.conf.local then they are not picked up. –  shonky linux user May 14 at 6:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.