Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a small network at home consisting of a Primary Domain Controller running Win 2008 R2, a desktop running Win 7 (x64), and a laptop running Win 7 (32-bit).

I'm not sure when this started or what changed, but from the laptop I can no longer access shares running on the desktop, either navigating in explorer, or by using a "NET USE" command. When navigating from explorer, it sees all three machines, but when I double-click on the desktop to expand it, it says "DWH-X64 is not accessible. You might not have permission... Login failure: The target account name is incorrect." Similarly, if I try to run a NET USE command it comes back "System Error 1396 has occurred. Logon failure: the target account name is incorrect."

If I try either of these procedures referencing the domain controller in stead of the desktop, they complete successfully. I can also access the laptop shares from the desktop.

I have Bing'd this error, and tried (repeatedly) removing the laptop from the domain and re-adding it (including going to the ActiveDirectory and deleting the machine account), and still get the same results. The other solutions that I've found on Bing seem not to apply, as they are talking about multiple domain controllers and replication.

Note also that I can login using this (supposedly incorrect) account name on all three machines.

I don't know what else to try. Any suggestions?

Thanks in advance

share|improve this question
1  
Check your Domain Controller Event Logs. (And make sure the DCs and clients systems are showing the same time. Being out of time sync with your DC can cause this too.) Here's a link to a KB article that applies to the issue with DC replication: support.microsoft.com/kb/2183411, but if you scroll down to known causes, you'll see some that can apply to a single DC environment as well. –  HopelessN00b Jul 17 '12 at 15:14
1  
That was the problem - the Windows Time service on the desktop had somehow gotten configured to source time from the local CMOS clock, instead of the PDC, so the time had drifted. I manually resynced the time within a second, but it still wouldn't recognize it, so I removed and re-added the desktop from the domain, and everything was happy. –  Dave Hanna Jul 21 '12 at 2:47

1 Answer 1

up vote 0 down vote accepted

The 'target account name' refers to the name of the computer you are connecting to.

Basically, you are attempting to call the server by a name which it does not recognise.

Things to check:

Can you connect to the server by IP address? Is your computer resolving the name of the server to the correct IP?

And - something else I've seen cause this issue (albeit with a Win2003 DC) - check that the "TCP/IP NetBIOS Helper" service is running on the server.

share|improve this answer
    
The fact that target account was referring to the computer name, not the logon name that I was trying to use was a big help. But nothing else seemed to fix it until I read the comment from HopelessN00b above, and that pretty much explained everything. (If that had been an answer instead of a comment, I would have checked that answer.) So my problem was that I should have removed and re-added the target machine to the domain, not the machine I was working from (and the clocks had drifted too far apart.) –  Dave Hanna Jul 21 '12 at 2:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.