Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just deployed an update to an existing ASP.NET MVC3 site (it was already configured) and I'm getting the IIS blue screen of death stating

HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred.

However; there is nothing showing up in the Application Event Log where I would expect to see a (more) detailed description of the entry.

How can I go about diagnosing this issue?

share|improve this question
    
What's the site written in? –  Kev Jul 15 '12 at 22:12
    
@Kev, sorry. It's .NET MVC3. I've updated the question. –  Greg B Jul 16 '12 at 7:56
    
I've had the exact same issue here. In my experience, if the event log is empty than the request wasn't correctly routed to the worker process. In one of our recent deployments we saw the app work intermittently with about 50% of the requests randomly failing with the 500 error and nothing in the logs. I suspect something is going wrong with the AppDomain unload that occurs after deployment. Out of curiosity, are you running antivirus in your production environment? Does an IIS reset solve the issue (until the next deployment)? –  ShadowChaser Feb 21 '13 at 16:17

2 Answers 2

up vote 10 down vote accepted

Take a look at IIS7's Failed Request Tracing feature:

Troubleshooting Failed Requests Using Tracing in IIS 7
Troubleshoot with Failed Request Tracing

The other thing I would do is tweak your <httpErrors> setting because IIS may be swallowing an error message from further up the pipeline:

<configuration>
  <system.webServer>
    <httpErrors existingResponse="PassThrough" />
  </system.webServer>
</configuration>

If the site is written in Classic ASP then be sure to turn on the Send Errors to Browser setting in the ASP configuration feature:

enter image description here

And finally, if you're using Internet Explorer then make sure you've turned off Show friendly HTTP error messages in the Advanced settings (though I suspect you've done that already or are using a different browser).

share|improve this answer
    
existingResponse was set to Replace. Thanks for the tip. –  Greg B Jul 16 '12 at 20:18

If upgrading from IIS6, then it may be one of the the web.config works on 6, but not in IIS 7.5 ... Double click on all the icons in IIS for the website and you may get an error about the format (Section must be below other section...)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.