Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  • Arch Linux 2011.08.19 (Linux 3.4.2 i686)
  • Apache 2.2.22 with SuExec
  • PHP 5.4.4 (cli) via FastCGI

My sites were all working fine earlier… I’m not sure when it happened because I noticed it over a week later (I’m guessing perhaps after a system upgrade), but all my VirtualHosts went offline with the dreaded “Premature end of script headers: php-fcgid-wrapper” 500 error.

SuExec logs gave me this for each site:

[2012-07-16 00:45:02]: uid: (1001/site) gid: (1001/site) cmd: php-fcgid-wrapper
[2012-07-16 00:45:02]: command not in docroot (/var/www/site/fcgi-bin/php-fcgid-wrapper)

This isn’t (or at least shouldn’t be) true… I automatically compile Apache with --with-suexec-docroot=/srv/www set. Still, I tried a sanity check, to see what docroot SuExec actually thought it had:

$ suexec -V
suexec policy violation: see suexec log for more details

For which the logs claimed:

[2012-07-16 01:07:52]: too few arguments

Tried it with sudo as well; same thing. So, even this makes no sense, and prevents me from being able to diagnose the problem properly.

Another thing I tried was moving everything from /srv/www to /var/www, the default docroot, to see if maybe it had reverted to the raw repository version during the upgrade. Updated my VirtealHosts, restarted Apache, but still got the same 500 errors.

What else could be causing this?

share|improve this question
Go back to a known good configuration. Create a testing environment from it and then work your way forward testing as you go. – Iain Jul 16 '12 at 7:04
This was my last known good configuration. I honestly don’t know what changed… – Hugh Guiney Jul 16 '12 at 18:16
Erm you say ... perhaps after a system upgrade ... surely you know if you did that or not ? – Iain Jul 16 '12 at 18:20
I did do that, but I don’t know that that is actually the cause of the problem; it’s just the only thing I can remember changing. Apache itself did not upgrade, and I didn’t edit any of my config files. I also don’t do full system backups currently, and Arch is rolling release anyway, so it’s non-trivial for me to attempt to recreate a previous server state here—I’d have to downgrade all of my packages manually. I’m willing to try it, but I think that’s a last resort. – Hugh Guiney Jul 16 '12 at 18:35
up vote 0 down vote accepted

You need to recompile suexec.c --with-suexec-docroot=/srv/www

share|improve this answer
I think you mean --with-suexec-docroot=/var/www . – Jenny D Jul 16 '12 at 7:35
How would this help? My docroot is /srv/www, and it was already compiled with that. – Hugh Guiney Jul 16 '12 at 22:37
So, I’m not sure why, but recompiling did actually solve this, albeit with my custom docroot specified. I was previously unable to recompile, but this answer to my related question on Unix & Linux got me there. – Hugh Guiney Jul 17 '12 at 0:01
OK I corrected this – Andrew Smith Jul 17 '12 at 7:12

You don't need to recompile it. You can use this package to set a custom path on debian or ubuntu:

apt-get install apache2-suexec-custom

After installing the package, there is a special directory, where you can set the suexec path for every user. There should be an example file für www-data user:


If you don't have Debian or Ubuntu, you have to look for such a package or recompile suexec with the right docroot (see suexec doc). The param is:


You have to check, how to do it for your distro.

share|improve this answer
I have Arch Linux, not Debian. See OP. – Hugh Guiney Jul 8 '13 at 15:07
recompile suexec with the path you need. I've added this to the answer. – Fa11enAngel Jul 10 '13 at 18:58

Find the fcgid configurations with this command:

/usr/lib/apache2/suexec -V

-D AP_DOC_ROOT="/var/www"
-D AP_HTTPD_USER="www-data"
-D AP_LOG_EXEC="/var/log/apache2/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_USERDIR_SUFFIX="public_html"

The wrapper must be written in the directory tree of: AP_DOC_ROOT to be accessed and run.

share|improve this answer

There's a www-data file (/etc/apache2/suexec/www-data) with 2 lines:


you can change that lines to what you prefer

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.