Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The magic_quotes_gpc PHP INI directive must be set to 'OFF' in order for OWA domstreams to operate correctly.

How do you make this change in Plesk server 9.5.4?

share|improve this question

1 Answer 1

There would be several options:

  1. IF you are using mod_php - add .htaccess file with php_admin_flag magic_quotes_gpc off in docroot of your site
  2. IF you are using mod_php and have server admin (root) privileges - create a file .../conf/vhost.conf in a folder where your domain is located. You will need assistance of server admin, if you don't have admin privileges.
  3. IF you are using CGI/FastCGI and have server admin privileges - edit /etc/php.ini file (impacts all sites). The file may have different location for some OSes, I am not completely sure for its location on Ubuntu.
  4. IF you are using CGI/FastCGI and need to apply this setting for one site only - refer to this article http://kb.parallels.com/9059

Alternatively you can upgrade to Plesk 10.4 or Plesk 11.0 and manage PHP settings from UI. It will also ensure your securiyt as older versions of Plesk were a subject of vulnerability recently.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.