Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a 1TB USB WesternDigital MyPassport External HDD plugged into our Windows 2008 R2 (64-bit) server (HP ProLiant ML110 G7) and when you go to eject the External HDD (to swap drives for backups), right-click and hit Eject MyPassport, it'll sit there for over a minute or two before it tells you its safe to unplug the device. It shouldn't be currently writing when we eject it, as all it does it Windows Server Backups on the hour and we're definitely not ejecting it while a backup is running.

Any idea what could be causing such long eject times?

share|improve this question
    
Have you tried switching it off and switching it on again? –  Chopper3 Jul 18 '12 at 19:02
    
Yep, sure have. –  David Jul 18 '12 at 19:04
add comment

2 Answers

Did you just write data the the external drive? (E.g. did you just write the backup to it?)

If you did then windows likely has not finished actually writing the data and that it has remaining unflushed data cached in RAM.

share|improve this answer
    
I've tried ejecting it 20-40 minutes after a backup has completed and it always takes 1-2 minutes. –  David Jul 16 '12 at 17:20
    
Try turning off indexing for that drive? –  SpacemanSpiff Jul 16 '12 at 17:41
    
Would that be under the drive's properties from Disk Management and un-checking "Allow files on this drive to have contents indexed in addition to file properties"? –  David Jul 16 '12 at 17:52
    
Yep, I believe so. Just trying to think of things that might continue to use the drive in the background. Maybe process explorer from sysinternals can show you what has locks there too –  SpacemanSpiff Jul 16 '12 at 18:10
    
Definitely didn't fix it by disabling indexing. Took 1m22s from the moment I clicked eject until it said it was safe to eject. –  David Jul 16 '12 at 18:17
show 1 more comment

Check to make sure delayed write is turned off.

Go to Disk Management. Right click on the disk itself (not the partition) and select Properties. Under Policies, you want it to be set to "Quick Removal".

share|improve this answer
    
Already is set to Quick Removal, by default. –  David Jul 16 '12 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.