Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


  • Reinstalled Windows 7
  • Installed Windows 8
  • Various Apache tweaks (AcceptFilter http none...)
  • Installed Windows XP

Some Wireshark log

1   0.000000000 HonHaiPr_0b:36:ae   D-LinkIn_64:ca:28   ARP 42  Who has  Tell
2   0.001844000 D-LinkIn_64:ca:28   HonHaiPr_0b:36:ae   ARP 42 is at 28:10:7b:64:ca:28

Works with XP, too bad PHP is dropping support.

Question: Should I throw router out of the window? I can't blame Windows (deep in my heart I want to)

I am experiencing (almost) random connection timeouts, with Apache on Windows7, to the extent that I'm afraid to hit F5... I cannot explain when it occurs, because I was unable to find pattern.

enter image description here

Computer that is giving me the troubles is the one that Mario wants to smack. Here is the fun part, it cannot be accessed from another Windows computer (while timeouts occur), but it can be from the Linux one. After timeout message occurs (about 30s later), it is usually working again, if not, I have to restart Apache. They are connected wirelessly to a cheap D-Link router, and later via cable.

When everything is functioning:

  • I can access from any computer
  • I can access from outside (internet) via DynDNS
  • I can access network (sharing) without problems
  • I have no headache

When it's not:

  • I can't access via HTTP (
  • I can't access from outside (internet) via DynDNS
  • I can access network (sharing) without problems
  • I can access from Linux computer in network
  • I can access from computer in question (
  • I have a mild headache

What have I tried:

  • Set MTU to 1500 everywhere
  • Updated Apache to 2.4.2 - 32bit
  • Disabled all F!r3w411z
  • Connected computer in question via Ethernet cable (timeouts are less frequent)


I do have 2-3 vhosts defined like this:

Listen *:1337

<VirtualHost *:1337>
ServerName l337
DocumentRoot C:/git/1337
    <Directory "C:/git/1337">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all

If question is too localized please do tell. Something similar:

Thank you for your time.

P.S. I have tried turning it off and on again.

share|improve this question
Anything in the Apache error.log? – Mathias R. Jessen Jul 16 '12 at 20:22
@MathiasR.Jessen Hi, just one line that is suspicicous (others are start/stop or PHP errors), [Sat Jul 14 14:44:51.222471 2012] [access_compat:error] [pid 796:tid 1112] [client] AH01797: client denied by server configuration: C:/apache2, referer:, however, I can't seem to find where is C:/apache2 from because it is C:/apache... – Dejan Marjanovic Jul 16 '12 at 21:47

The answer is:

enter image description here

P.S. don't expect much from cheap DLink (or any other probably) router.

share|improve this answer

If you are attempting to connect using an ip address and it is working all the time from linux (I am a windows admin so I hate to say) it is most likely windows, since all the machines with issues are running windows.

Are your pings completing to and from all the windows machines when things are trying to give you a headache?

Does anything else try to run on port 80 before things go wrong? (Skype, IIS, SQL)

Have you tried setting Apache to use port 8080?

If you really think that the router is the issue, try this:

  1. take it off of the internet
  2. replace the router (temporarily) with a simple hub or switch
  3. try connecting

It is possible that the router is the issue, but cheap does not mean "doesn't work". Not every network needs the "bigger better faster more" hardware solution.

share|improve this answer

It seems that you may be getting these errors based on your apache configuration found under apache/Conf/httpd.conf.

share|improve this answer
I really don't think so because I tried almost every configuration, and again, it works good on XP, but not on Vista+ ... after I changed router it might have occurred 1-2 times, but worked right away after. – Dejan Marjanovic Aug 29 '12 at 13:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.