Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running Windows 2003, it has a hardware RAID controller (4 disks in RAID5, health all OK)

The server will boot into standard mode or safe mode (from the array) but once windows is running, you cannot access the drive (Windows OS thinks the drive is RAW).

When you attempt to open C drive, it says access denied.

I need to know the direction I should diagnose. Does this sound like a RAID issue, partition issue, or a malware/virus compromising the system? It seems odd that Windows will start... if it were a RAID or partition issue Windows shouldn't start, correct?

share|improve this question
1  
Bizarre! Could be malware I suppose, can you see the drive contents if you boot into the recovery console? –  Chris McKeown Jul 16 '12 at 19:47
    
It does not sound like a RAID issue, it sounds most likely like a windows issue. If it was a problem with the RAID, you wouldn't be able to boot in the first place. A virus is possible, but my bet would be on windows acting stupid, or possibly some weird configuration issue. I wish I could say more, but you can be pretty confident that it's not the RAID. –  Matthew Jul 16 '12 at 19:47
1  
Try running chkdsk /r against the partition, if it asks to run on next reboot, say yes and reboot it. This sounds like an error with Windows and its partition table. –  DanBig Jul 16 '12 at 19:47
    
Sounds like Windows is mounting a different drive to C:. Remember that Windows does not actually have to mount the drive it booted off, and C: is not automatically the drive it booted from either. –  Chris S Jul 16 '12 at 22:57
add comment

2 Answers 2

up vote 5 down vote accepted

Here is a direction to go.

During BOOT you are running of the rudimentary drivers built into the Firmware of the RAID card. Once Windows takes over (starts up) you are running off the Windows drivers and any management software you installed. - The problem is Windows based, not hardware.

If possible image all your drives (individually) before you do anything else.

You might try temporarily installing a non-RAID drive and setting it as the BOOT drive - then install an NT based OS (W2k, W2k3, XP, etc should do) to that temp drive and see if you can gain access to your array. If so, BACK UP EVERYTHING!.. .

share|improve this answer
    
Windows RAID driver issue (corruption?) was culprit as you suggested. Replaced driver in recovery console and array responded properly again. –  osujc Jul 16 '12 at 23:30
    
Awesome! - Glad you're fixed! - - My round-about way (OS on another drive) was to minimize the potential for data loss, but if what you did worked - it worked. –  PCBONEZ Jul 16 '12 at 23:48
add comment

The boot and system volume doesn't need to be C: I'm betting that you managed to install windows to a different volume and C: is really raw. Check your other volumes for a Windows folder to verify this.

share|improve this answer
1  
Awe, you beat me to it. –  Chris S Jul 16 '12 at 22:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.