Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed OpenVZ on my VMWare box (To do some testing) and I get the following:

the GRUB config is as follows:

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
title OpenVZ (2.6.32-042stab057.1)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-042stab057.1 ro root=/dev/VolGroup00/LogVol00 sysfs.deprecated=1
        initrd /initrd-2.6.32-042stab057.1.img
title CentOS (2.6.18-238.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-238.el5 ro root=/dev/VolGroup00/LogVol00
        initrd /initrd-2.6.18-238.el5.img
share|improve this question
up vote 0 down vote accepted

This one usually occur when you are installing OpenVZ on wrong repo.I assume that the host node operating system that you are using is CentOS 5.To fix this you need to reinstall again your OpenVZ.

First you must remove the OpenVZ.After that try to edit the repository of OpenVZ at /etc/yum.conf.d/openvz.repo

You should find something similar like this.You no need to change the line enabled from 0 to 1 :

name=OpenVZ RHEL5-based kernel

Don't forget to change other settings(openvz-kernel-rhel4 and openvz-kernel-rhel5) to enabled=0.

After editing that file,run this command :

yum install ovzkernel

You should good to go.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.