Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Tried navigating to my server today and noticed that NONE of my hosted websites are loading...even if I enter the ip and try to hit the default page I get nothing. I hadn't touched the server since it was working properly so I'm not sure what has happened. I made a couple little changes and tried to restart apache and whenever I try I get this:

jcmo:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:443 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:443 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Mon Jul 16 21:13:10 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
 failed!

Any ideas would be greatly appreciated!

share|improve this question
    
You'll have to check your httpd.conf or vhost configuration file and see what's happening there - maybe a stray character somewhere? Use apachectl to parse your config files and see if they're OK. –  Ansari Jul 17 '12 at 2:39
    
You should post the output of: grep VirtualHost /etc/apache2/* grep VirtualHost /etc/apache2/sites-enabled/* And any uncommented <VirtualHost> blocks (obscuring sensitive info if there is any) –  sss Jul 17 '12 at 2:44
    
Btw this is just a warning so you Apache server should still run. –  golja Jul 17 '12 at 3:00
    
Are there any relevant error messages in your error log ? –  Iain Jul 17 '12 at 6:53
    
Jason is helping me and it seems that I caused this problem. Apache was looking for a 'logs' directory in one of the sites. I think I deleted it. When I re-created the directory Apache started. –  dbasnett Jul 17 '12 at 16:21

1 Answer 1

Do you have still space left in the mount that holds /var/log? Are the log file/dir permissions OK? Too many times everything else has been fine for me, but something related to logging has bugged Apache.

share|improve this answer
    
There seems to be space available –  dbasnett Jul 17 '12 at 13:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.