Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an old Buffalo HS-DH500GL NAS. I bought it years ago (2007 I think) when I heard it could be upgraded to run Debian 4.0. I followed some random tutorial (long forgotten where I found it) to install Debian, and the box has been running fine on my shelf for years. I have hardly used it, but I would like to start using it more and have found that everything is out of date on it. I decided to try to get it all up-to-date, but when I run aptitude to update everything, I'm getting all kinds of 404 errors. I'm guessing everything has been moved to the archive servers.

What I would LIKE to do is start from scratch, wipe everything, and install a fresh (and up to date) OS. I only have access to it via SSH (no serial port). Any ideas how to go about this? Would it be possible/feasible to take the HDD out of the NAS, and on another computer copy over some install of a new OS?

share|improve this question

closed as off topic by EEAA, Ignacio Vazquez-Abrams, Shane Madden, Ward, Tom O'Connor Jul 17 '12 at 15:56

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
do you know what architecture the nas is? is it armel? is it i386? –  stew Jul 17 '12 at 4:20
    
your title labels it as "hacked", what do you mean by that? –  stew Jul 17 '12 at 4:21
    
@ stew - Sorry, I can see that saying "hacked" might be misleading; Buffalo doesn't officially support installing 3rd party OS's on the NAS. There's a NAS community which "hacks" the boxes into fully-fledged Linux servers; also, I think the architecture is ARM9. –  loneboat Jul 17 '12 at 4:32
    
@user49704 - I've changed you title to something more accurate –  Mark Henderson Jul 17 '12 at 4:38

2 Answers 2

up vote 2 down vote accepted

Taking the hard drive out to put into another machine in order to freshly install debian is often a very workable solution, however, in your case, where you are unlikely to have another machine of the same architecture to drop the hard drive into, this is a lot less convenient. This is still possible using debootstrap, but debootstrap doesn't do a full installation. it just installs some packages, you are left to do a lot of the renaming stuff that the installer would do, like setting up /etc/network/interfaces, /etc/hosts, /etc/resolv.conf, /etc/hostname, installing a bootloader, and kernel.

Upgrading from etch to squeeze is a definite possibility. Just note that there was a lenny release which you should not skip on your way from etch to squeeze.

here's what I'd recommend:

Note first that the current etch repositories have moved, since, it is so far beyond end-of-life. the current etch respoitory is this:

deb http://archive.debian.org/debian etch main

use just that, then apt-get update and apt-get upgrade then apt-get dist-upgrade to make sure you are up to date with the latest etch. Then upgrade to lenny by following chapter 4 of the lenny release notes. Keeping in mind that also lenny is past end-of-life, so the repository for lenny is now:

deb http://archive.debian.org/debian lenny main

So use the above repository when you get to section 4.4 of the lenny release notes. After upgrading to lenny, you should be able to upgrade to squeeze by following chapter 4 of the squeeze release notes.

These instructions in the release notes might seem much more complicated when compared to some advice you'll get to just "change sources and dist-upgrade", but we've arrived at these instructions through lots of independent testing, and these instructions should have a much greater probability of actually leaving you with a working install.

share|improve this answer

Sounds like your aptitude sources are not loading properly. Edit the file /etc/apt/sources.list and make sure they are using the correct repositories for Debian 4.0 "Etch" which should looks something like this:

deb http://archive.debian.org/debian/ etch main contrib non-free
deb-src http://archive.debian.org/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

Notice I included the non-free option, this is of course, your prerogative. After editing this file run the commands apt-get update to update the repositories and then apt-get upgrade to run the upgrades on your system for all packages.

Otherwise, a quick Googling seems to indicate that your device would handle Debian 6 "squeeze" and so you might choose to go that far. In which case, replace the repositories in the file where it says etch to squeeze and run apt-get update and then apt-get dist-upgrade to upgrade your distro to 6.

Note, moving from "etch" to "squeeze" (meaning you're skipping the 5 distro "lenny" in between) could be more intense, while at the same time, depending on the software and packages you have installed, could be no problem at all. So in the case of running into trouble or if you're being extra cautious check out a tutorial such as this: http://www.cyberciti.biz/tips/howto-upgrade-debian-linux-4etch-to-5lenny-server.html that has good pointer on upgrades.

share|improve this answer
    
Those are not the correct repositories for etch. since etch was officially at "end-of-life" over two years ago, and there have been at least two subsequent releases, etch is no longer carried on the main mirrors, but, instead is on archive.debian.org/debian . –  stew Jul 17 '12 at 4:17
1  
if one were to upgrade from etch to squeeze one should NOT do so by skipping lenny. upgrading to lenny first (by following chapter 4 of the lenny releaes notes) then upgrading to squeeze (by following chapter 4 of the squeeze releaes notes) is FAR more likely to actually work –  stew Jul 17 '12 at 4:18
    
there really is no reason to go to some random third party "how to upgrade" blog posting, when debian makes such detailed and well tested procedures available in the release notes –  stew Jul 17 '12 at 4:19
    
@stew: In my defense, I did say "looks SOMETHING LIKE this" I just corrected the repositories to reflect that they are in the archive. Your second two comments are based on opinion. I did mention upgrading straight to squeeze might be scary, but in the end, it has worked plenty of times for me with no ill consequences. It just matters what risks you're willing to take. Lastly, whether the official manual or another tutorial is the best is solely your opinion. –  Tyler Jul 17 '12 at 4:50
    
"deb security.debian.org etch/updates main contrib non-free" will still certainly lead to 404, there haven't been security updates for etch for years now –  stew Jul 17 '12 at 4:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.