Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is the topology I have set up in my GNS3.

RIP-EIGRP Topology

The RIP V2 protocol of Router R2 is recognizing and advertising the two networks that are advertised in EIGRP, even though the said information should only have been received through redistribution. How Do I ensure that RIP advertises only those subnets I want advertised and not all the subnets of that Classful network that may exist on that particular router?

The below is the Show Ip route and Show Running-config informations from the routers R2 and R3,

    R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 5 subnets, 2 masks
C       192.168.1.64/28 is directly connected, Loopback1
R       192.168.1.32/28 [120/1] via 192.168.1.133, 00:00:00, Serial0/0
R       192.168.1.16/28 [120/1] via 192.168.1.133, 00:00:00, Serial0/0
R       192.168.1.128/30 [120/1] via 192.168.1.133, 00:00:00, Serial0/0
C       192.168.1.132/30 is directly connected, Serial0/0
R3#

//////////////////////////////////////////////////////////////////////////////

R3#sh run
Building configuration...

Current configuration : 1063 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 192.168.1.65 255.255.255.240
!
interface Serial0/0
 ip address 192.168.1.134 255.255.255.252
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router rip
 version 2
 passive-interface default
 network 192.168.1.0
 neighbor 192.168.1.133
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R3#s


//////////////////////////////////////////////////////////////




R2#sh run
Building configuration...

Current configuration : 1240 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 192.168.1.17 255.255.255.240
!
interface Loopback2
 ip address 192.168.1.33 255.255.255.240
!
interface Serial0/0
 ip address 192.168.1.130 255.255.255.252
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/1
 ip address 192.168.1.133 255.255.255.252
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router eigrp 10
 network 192.168.1.16 0.0.0.15
 network 192.168.1.128 0.0.0.3
 no auto-summary
!
router rip
 version 2
 passive-interface default
 network 192.168.1.0
 neighbor 192.168.1.134
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
share|improve this question

1 Answer 1

up vote 0 down vote accepted

You can use a distribute-list to stop RIP from advertising the routes that are part of both the EIGRP and RIP processes (namely 192.168.1.16/28 and 192.168.1.128/30)

To do this simply allow the loopback 1 route out, and deny the rest. Alternatively you could write an access list that denies 192.168.1.16/28 and 192.168.1.128/30 and permit the rest.

You may also wish to use a prefix list if you want specific matches on the subnet length. Note the ACL below will actually allow any route that is a subset of 192.168.1.32/28 (e.g 192.168.1.33/32 would be permitted as well if it existed in your rip process)

router rip
 distribute-list 10 out s0/1

access-list 10 permit 192.168.1.32 0.0.0.15
access-list 10 deny any

This is a problem with RIP in that it can only be enabled on classful networks, which unfortunately in your topology means that RIP is running on all of the interfaces of the 192.168.1.0/24 network.

As you noted with EIGRP you don't have this issue since you can specify participating interfaces classfully.

share|improve this answer
    
Thank you. I shall certainly try that solution. –  gokul varma nk Jul 20 '12 at 8:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.