Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
How to send emails and avoid them being classified as spam
Email postfix marked as spam by google

I'm having a few issues sending email from our mail server. Most seem to work, but some addresses are getting picked up as Junk/Unsafe.

We run our own mail server sitting on Ubuntu on IP 192.168.0.9, and on this mail server(Zimbra) we have approx 15 different domains for sending emails.

Our emails are then send from our server, via our fibre router(so via the external IP of the router).

Our external IP's RDSN resolves to mail.ourmaindomainname.com which we want it to.

All of our domain names(hosted on a different external web server) have A records and MX records.

e.g if we had test-domain.co.uk the following occurs:

MX points to mail.test-domain.co.uk and the A record (mail.test-domain.co.uk) points to the external ip address of our email server, which is what we need it to be.

Any suggestions how I can work out whats going on, or how I can stop these being picked up by spam/junk etc?

I've seen one thing, on mxtoolbox, whereby I did an SMTP test, and it says: Warning - Reverse DNS does not match SMTP Banner

I think this could be because i'm sending from say test-domain.co.uk but the server is setup to ourmaindomainname.com but as we only have 1 IP address, I need the rdns to be from mail.ourmaindomainname.com

Thanks for the help

share|improve this question

marked as duplicate by symcbean, Ward, mailq, rnxrx, Michael Hampton Sep 6 '12 at 22:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
You should try to actually catch a message which was filtered and then examine that as to why it was filtered. There are far too many possibilities as to just "poke around" –  MichelZ Jul 17 '12 at 8:56
    
This is asked very frequently and different answeres have slightly different slants - you need to look at PTR and SPF records, and rate lmiting for some recipient domains. But these still won't solve all the prolems. –  symcbean Jul 17 '12 at 11:54
    
Also, to note, A while back when we migrated to Fibre, we asked BT(our fibre supplier) to setup the PTR records: EXTERNALIP > mail.ourmaindomain.com so that is already in place. Nothing todo with SPF though.. –  MercJones Jul 17 '12 at 12:24

2 Answers 2

In this thread you find 2 tools: Email test and Mx toolbox these tools give very good info to check all relevant stuff you need to configure your email server. (like SPF/DKIM/Reverse DNS/etc..)

Good luck!

share|improve this answer
    
I just notice you mention mxtoolbox in your question. This reverse DNS doesn't match SMTP banner problem I explain also in the link I gave in the above question –  Joost Verdaasdonk Jul 17 '12 at 9:00
    
I've done a PTR check on the IP address(main external ip) and it resolves to mail.ourmaindomainname.com, should the SPF record be checked against the main domain(mail.ourmaindomain.com) or the domain i'm having problems with? –  MercJones Jul 17 '12 at 12:17
    
I've 2 domain's and created SPF for both domain and sub domain but here: serverfault.com/questions/322949/… another option include is used. Never used it before but perhaps you can try. What I normaly do with setting up a mail server is used the above tools and setup everything so all is validated. After this I start testing if my mail works ok. ;-) Good luck –  Joost Verdaasdonk Jul 17 '12 at 12:41
    
I've now added a SPF record for that domain, which is: v=spf1 a mx ip4:EXTERNALIP/32 -all its picked up the SPF record straight away, but when emailing hotmail, it's still going to the junk account –  MercJones Jul 17 '12 at 15:44
    
I think hotmail is using these rules: mail.live.com/mail/services.aspx Perhaps you can give me the domain your sending email with so I can try out some tools to help you find clues. –  Joost Verdaasdonk Jul 17 '12 at 16:19

Something like this happened with my web hosting provider as well and I think after I switched to a dedicated server the problem stopped. So it might be that the same is happening with your servers.

Regards, Ihsan

share|improve this answer
    
We host our own email internally, and we have a dedicated server where all our domains are registered to/hosted and have all the A/MX records etc configured on. –  MercJones Jul 17 '12 at 12:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.