Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My server is telling my that binary logging is disabled. When I do a mysqladmin variables, I see this: log_bin | OFF. This is my configuration file:

# These are some standard (Plesk) options needed:
datadir             = /var/lib/mysql
socket              = /var/lib/mysql/mysql.sock
user                = mysql
old_passwords           = 1

# Some general options:
default_storage_engine      = MyISAM
#   We want to make sure eventual data loss is handled correctly:
myisam_recover          = FORCE,BACKUP

# Some security things, to avoid overloading:
max_allowed_packet      = 16M
max_connect_errors      = 1000000

# The important stuff, caching and performance tweaks:
max_connections         = 100
key_buffer_size         = 50M
read_buffer_size        = 2M
sort_buffer_size        = 5M
myisam_use_mmap         = 1
tmp_table_size          = 16M
max_heap_table_size     = 16M
query_cache_type        = 1
query_cache_size        = 64M
thread_cache_size       = 25
open_files_limit        = 65535
table_definition_cache      = 1024
table_open_cache        = 1024

# Although InnoDB is not used, some default optimization options:
innodb_buffer_pool_size     = 32M
innodb_data_file_path       = ibdata1:10M:autoextend
innodb_flush_log_at_trx_commit  = 2

# And finally some logging:
log_error           = /var/lib/mysql/mysql-error.log
log_queries_not_using_indexes   = 0
slow_query_log          = 1
slow_query_log_file     = /var/lib/mysql/mysql-slow.log

# Master
server-id = 1

So, I did mysqladmin shutdown and then a service mysqld start and after that mysqladmin variables. But it says log-bin | OFF? What am I doing wrong? We are using MySQL 5.5.18-ccl by the way.

share|improve this question
Did you check the error log after restarting? – symcbean Jul 17 '12 at 11:45
Yes, nothing interesting in there. It seems like it doesn't log also. – Kevin Jul 18 '12 at 6:41
Did you check mysql user can write to the logs? That it's using the config file you've shown above? – symcbean Jul 18 '12 at 8:00
Is the user mysql (group mysql)? Should it also be able to read the /etc/my.cnf? – Kevin Jul 18 '12 at 8:51
what happens when you run "SHOW MASTER STATUS;" ?? – Ed Manet Jul 19 '12 at 18:25
up vote 1 down vote accepted

Make sure mysql is the owner of /var/lib/mysql as follows:

cd /var/lib
service mysql stop
chown -R mysql:mysql mysql 
service mysql start

Another thing to check for is the presence of another my.cnf

Try the following

cd /var/lib/mysql
ls -l my.cnf

If a my.cnf file is there, you have found your culprit. Just rename the file

mv /var/lib/mysql/my.cnf /var/lib/mysql/my.cnf_old

and then service mysql restart

share|improve this answer


log-bin-index = /var/lib/mysql/mysql-bin.index


share|improve this answer
Actually I guess specifying this doesn't matter... I take it back. – HTTP500 Jul 19 '12 at 17:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.