Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

With Windows XP, I used to access machines in the network (under a domain) via administrative share (hidden share, a.k.a. "C$"), authenticating myself as the local admin of each respective machine.

Recently, the machines were upgraded to Windows 7. And now, when I try to access them via administrative share on Windows 7, it forces me to authenticate under the domain.

Later I did some test with some Windows XP machines back again in the domain and it worked.

So... is it possible to do it in Windows 7 as local admin, like I used to do in Windows XP? (I really hope there's a way...)

share|improve this question
    
Have you tried? Like have you typed in .\localadminaccount or machinename\localadminaccount??? Just because it tries to make you connect as a domain user by default, doesn't mean that's the only way to connect. :/ –  HopelessN00b Jul 17 '12 at 20:59
add comment

3 Answers 3

Try typing in .\localadminaccount or machinename\localadminaccount in the username field of the credentials dialogue that pops up. Just because it tries to make you connect as a domain user by default, doesn't mean that's the only way to connect. ;)

share|improve this answer
add comment

The local administrator account is disabled by default under 7. Best practice would be to leave it as such.

If you really want a local admin accounts you can create an accounts set passwords, etc - with group policy preferences as well as assign the new account to the local administrators group.

The better practice would be to create a new domain group - say 'desktop admins' - and assign this group to the local administrators group. Put your domain accounts into this group to provide access.

share|improve this answer
add comment

You can enable this behaviour by adding the registry key descibed at http://support.microsoft.com/kb/951016.

Basically:

Under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Set:

LocalAccountTokenFilterPolicy = DWORD 0x1

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.