Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having a real headache configuring a new server. It's a 64bit Linux box with Centos 6 and Plesk 11. This will be a Magento server, so I need mcrypt installed, which isn't available by default.

I've installed EPEL 6, confirmed here:

[root@ds-xxxxxxx ~]# yum repolist
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.mirroring.pulsant.co.uk
 * epel: mirror.affix.me
 * extras: centos.mirroring.pulsant.co.uk
 * rpmforge: www.mirrorservice.org
 * updates: centos.mirroring.pulsant.co.uk
repo id                repo name                                                    status
base                   CentOS-6 - Base                                              6,346
epel                   Extra Packages for Enterprise Linux 6 - x86_64               7,070
extras                 CentOS-6 - Extras                                                4
rpmforge               RHEL 6 - RPMforge.net - dag                                  4,392
updates                CentOS-6 - Updates                                             165
repolist: 17,977
[root@xxxxxx ~]#

But when I run a yum update, it looks like it's trying to load el5 & el6 extensions/modules so causes an issue;

# yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.mirroring.pulsant.co.uk
 * epel: mirror.affix.me
 * extras: centos.mirroring.pulsant.co.uk
 * rpmforge: www.mirrorservice.org
 * updates: centos.mirroring.pulsant.co.uk
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.1-2.el6_0.1 will be updated
---> Package git.x86_64 0:1.7.4.1-1.el5 will be an update
--> Processing Dependency: libcrypto.so.6()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libexpat.so.0()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: git-1.7.4.1-1.el5.x86_64
---> Package libarchive.x86_64 0:2.8.3-4.el6_2 will be updated
---> Package libarchive.x86_64 0:2.8.4-5.el5 will be an update
---> Package mod_wsgi.x86_64 0:3.2-1.el6 will be updated
---> Package mod_wsgi.x86_64 0:3.2-2.el5 will be an update
--> Processing Dependency: libpython2.4.so.1.0()(64bit) for package: mod_wsgi-3.2-2.el5.x86_64
---> Package perl-Git.noarch 0:1.7.1-2.el6_0.1 will be updated
---> Package perl-Git.x86_64 0:1.7.4.1-1.el5 will be an update
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Git-1.7.4.1-1.el5.x86_64
---> Package python-ethtool.x86_64 0:0.6-1.el6 will be updated
---> Package python-ethtool.x86_64 0:0.6-2.el5 will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-ethtool-0.6-2.el5.x86_64
--> Running transaction check
---> Package compat-expat1.x86_64 0:1.95.8-8.el6 will be installed
---> Package git.x86_64 0:1.7.4.1-1.el5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.7.4.1-1.el5.x86_64
---> Package mod_wsgi.x86_64 0:3.2-2.el5 will be an update
--> Processing Dependency: libpython2.4.so.1.0()(64bit) for package: mod_wsgi-3.2-2.el5.x86_64
---> Package openssl098e.x86_64 0:0.9.8e-17.el6.centos.2 will be installed
---> Package perl-Git.x86_64 0:1.7.4.1-1.el5 will be an update
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Git-1.7.4.1-1.el5.x86_64
---> Package python-ethtool.x86_64 0:0.6-2.el5 will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-ethtool-0.6-2.el5.x86_64
--> Finished Dependency Resolution
Error: Package: git-1.7.4.1-1.el5.x86_64 (epel)
           Requires: libcurl.so.3()(64bit)
Error: Package: perl-Git-1.7.4.1-1.el5.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: mod_wsgi-3.2-2.el5.x86_64 (epel)
           Requires: libpython2.4.so.1.0()(64bit)
Error: Package: python-ethtool-0.6-2.el5.x86_64 (epel)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-29.el6_2.2.x86_64 (@base)
               python(abi) = 2.6
           Available: python26-2.6.8-1.el5.x86_64 (epel)
               python(abi) = 2.6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
share|improve this question

1 Answer 1

up vote 0 down vote accepted

So after a few rebuilds and tweaking I discovered the issue was the order in which I installed things on the server. The issue seems to have been plesk 11 being installed first. So I rebuilt the server, installed the el6 repo first, then mcrypt and yum updates, then installed plesk.

Works like a charm now.

Hope this helps someone else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.