Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a serious issue with trying to get WSUS 3 working. It was installed and working fine on Windows Small Business Server 2008 for a couple years, but then stopped working completely. I researched the errors, but couldn't find anything related, so did a manual uninstallation of WSUS 3.0 SP2 following the directions at http://www.fixkar.com/articles/kb/1161/ . I figured if I uninstalled, a clean reinstall would fix everything. Not so much.

When I tried to reinstall, I got errors that I tracked down to the Update Services registry key being missing (deleted per directions in the link above). I exported it from a working server, reimported it to this server, and tried the install again. Even though it's uninstalled manually, when I run the installer it will only let me try to uninstall again. It gets partway through the 'uninstall', then errors out with

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2753.

The only thing showing in the application event log is

Product: Windows Server Update Services 3.0 SP2 -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2753. The arguments are: f_HideConsoleApp.exe

I've tried searching exhaustively through Google for these errors, but have found nothing that works for me so far.

I've uploaded the logs at www.blackwoodtech.com/wsus but don't have enough knowledge (yet) to figure out where the problem lies.

Is anyone able to help with this? I'll be monitoring this thread closely and will respond as quickly as I am able. I do need to get this solved as soon as possible.

share|improve this question
1  
The absolute first thing I suspect when Windows mysteriously stops obtaining updates is malware. Have you fully scanned the system? –  Michael Hampton Jul 18 '12 at 3:49
    
Is reinstalling the OS as well an option? Even if it's not malware like suggested above, it sounds like the OS install might not be completely healthy. If possible, I'd want to wipe the hard drive, and rebuild on something I know to be pristine. –  HopelessN00b Jul 18 '12 at 11:33
    
I've done several malware checks and found nothing. This is the only server at this business, and a full reinstall would be a major problem for them. I've already floated this by them, and was quickly shot down. –  Richard Blackwood Jul 19 '12 at 0:21
    
Well, I finally managed to get the Microsoft Software Installer Clean Up Utility (MSICUU) to work correctly, and removed the installation of WSUS 3.0 from the list. Once I did that, it reinstalled with no problem, and is currently syncing the updates again. Woohoo. I do appreciate the suggestions and help. I had tried this before, but apparently it worked this time. –  Richard Blackwood Jul 19 '12 at 1:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.