Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My VOIP provider required me to add this into /etc/asterisk/extensions.conf:

exten => h,1,Hangup
exten => _00X.,1, Answer
exten => _00X.,n, Set(CALLERID(num)=96354205144239) ;
exten => _00X.,n, Dial(SIP/${EXTEN}@Trunk_Name)
exten => _00X.,n, Hangup

Could you please explain what is this syntax mean and what can it do .?

Also how to add this syntax using Elastix GUI instead of adding it manually into extenisons.conf.

share|improve this question

3 Answers 3

It looks like they are trying to have you set your outgoing Caller ID string to that sequence of digits (which you should probably obscure). It should be sufficient to set your outgoing Caller ID for the outgoing SIP trunk to that value.

share|improve this answer

It appears your provider doesn't understand Asterisk very well (unless the provider is doing something very non-standard, it's wrong to "Answer" the call at this point) but the main thing that this appears to be doing is setting your outgoing Caller ID number to 96354205144239. Assuming that you have created an outgoing trunk in Elastix (actually in FreePBX), you can achieve the same effect by going to the trunk settings page for the provider, and setting the Outbound CallerID field to that number, and then setting the CID Options dropdown to Force Trunk CID. Those two changes will most likely be all you'll need, again assuming you have your trunk configured correctly otherwise. Don't forget to "Submit Changes" and do an orange bar reload after making the above modifications to the trunk configuration. And note that you cannot modify extensions.conf directly in FreePBX anyway, because if you do, any changes you make will be overwritten the next time you make any other change in FreePBX. So do it on the FreePBX (Elastix) trunk configuration page for your trunk for this provider.

share|improve this answer

This is nothing but the provider sets the Outbound caller ID to that number. If you have a outbound trunk you can do it by setting CALLERID in the GUI. Click on the outbound trunk, change the CALLER ID and reload Asterisk.

Regards

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.