Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I looked at many articles and can;t quite seem to find an answer that work so here goes. I'm setting up a DHCP server running Ubuntu 12.04 LTS, but I'm unable to get the phones to get an IP address. These are Avaya phones that require the Option-176 with all of the string that follows see below. If I comment out the DHCP information for one of the VLANs and connect the phone is seems to work fine but on the actual vlan for phones no go. I'm sure the fix is simple and hope that you can point it out for me. Thanks.

From the dhcpd.conf

shared-network OVKData {
subnet 192.168.226.0 netmask 255.255.255.0 {
    option routers 192.168.226.1;
    option broadcast-address 192.168.226.255;
    range 192.168.226.30 192.168.226.100;
    option option-176 "MCIPADD=192.168.30.3,192.168.30.4,MCPORT=1719,TFTPSRVR=192.168.222.129,L2Q=1,L2QVLAN=888,VLANTEST=0";
#   option option-176 "L2Q=1,L2QVLAN=888,VLANTEST=0";
#   option option-176 "MCIPADD=192.168.30.3,192.168.30.4,MCPORT=1719,TFTPSRVR=192.168.222.129";
    }
#shared-network OVKVoice {
subnet 192.168.98.0 netmask 255.255.255.0 {
    option routers 192.168.98.1;
    option broadcast-address 192.168.98.255;
    range 192.168.98.30 192.168.98.100;
#   option option-176 "MCIPADD=192.168.30.3,192.168.30.4,MCPORT=1719,TFTPSRVR=192.168.222.129,L2Q=1,L2QVLAN=888,VLANTEST=0";
    option option-176 "L2Q=1,L2QVLAN=888,VLANTEST=0";
    option option-176 "MCIPADD=192.168.30.3,192.168.30.4,MCPORT=1719,TFTPSRVR=192.168.222.129";
    }
}

From the interfaces

auto vlan226
auto vlan888
#auto vlan300

# OVKData vlan888
iface vlan226 inet static
    address 192.168.226.4
    netmask 255.255.255.0
    gateway 192.168.226.1
    network 192.168.226.0
    broadcast 192.168.226.255
    mtu 1500
    vlan_raw_device eth0

# OVKVoice Vlan 888
iface vlan888 inet static
    address 192.168.98.4
    netmask 255.255.255.0
    gateway 192.168.98.1
    network 192.168.98.0
    broadcast 192.168.98.255
    mtu 1500
    vlan_raw_device eth0

FRom Syslog

Jul 17 13:20:17 NOCDHP dhcpd: DHCPOFFER on 192.168.226.32 to 00:04:0d:29:3b:f9 via vlan888
Jul 17 13:20:17 NOCDHP dhcpd: DHCPDISCOVER from 00:04:0d:29:3b:f9 via vlan888
Jul 17 13:20:17 NOCDHP dhcpd: DHCPOFFER on 192.168.226.32 to 00:04:0d:29:3b:f9 via vlan888
Jul 17 13:20:17 NOCDHP dhcpd: DHCPDISCOVER from 00:04:0d:29:3b:f9 via 192.168.98.5
Jul 17 13:20:17 NOCDHP dhcpd: DHCPOFFER on 192.168.226.32 to 00:04:0d:29:3b:f9 via 192.168.98.5
Jul 17 13:20:17 NOCDHP dhcpd: DHCPDISCOVER from 00:04:0d:29:3b:f9 via 192.168.98.1
Jul 17 13:20:17 NOCDHP dhcpd: DHCPOFFER on 192.168.226.32 to 00:04:0d:29:3b:f9 via 192.168.98.1
Jul 17 13:20:17 NOCDHP dhcpd: DHCPDISCOVER from 00:04:0d:29:3b:f9 via 192.168.98.1
Jul 17 13:20:17 NOCDHP dhcpd: DHCPOFFER on 192.168.226.32 to 00:04:0d:29:3b:f9 via 192.168.98.1
Jul 17 13:20:17 NOCDHP dhcpd: DHCPDISCOVER from 00:04:0d:29:3b:f9 via vlan888
share|improve this question
add comment

2 Answers

I believe the problem you are having is that you have actually commented out the incorrect strings in the opposite VLAN's DHCP scopes.

On the data VLAN all you wish to do is tell the handsets to look at the voice VLAN, hence you only need the following string in the data DHCP scope

option option-176 "L2Q=1,L2QVLAN=888,VLANTEST=0"

Then on the voice VLAN you would want to have the string:

option option-176 "MCIPADD=192.168.30.3,192.168.30.4,MCPORT=1719,TFTPSRVR=192.168.222.129"

Maybe I'm overlooking something because I have never used Linux before as a DHCP server, but this seems to be the reason, especially because you can get it to work on the data VLAN.

share|improve this answer
add comment

You didn't mention which Avaya phones. Some have a bug in the firmware which prevent them from hopping VLANs for initial configuration -- IIRC, the screen indicates that the DHCP server never responds, when in fact the phone never changes VLANs or makes the DHCP request.

Use craft configuration to manually specify your voice VLAN on one phone, and see if it can connect to the call server. If it can, then get in touch with your Avaya business partner and complain about the phones. ;)

If that doesn't work, then I agree with the answer from Linden and revised by HopelessN00b: your option-176 configuration is not quite right; follow their advice.

share|improve this answer
    
Thanks for the input I will make the adjustment and see if this works. –  Rick Dec 28 '12 at 15:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.