Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have internal domain setup as corp.example.com however when I try to join it computers cant find it. When I ping corp.example.com I am getting response from my external example.com

Problem is that for some reason computers are looking for corp on example.com (external) instead of internal. How can this be fixed. I know that I can add entry to hosts file but I am looking for more elegant (proper) solution.

Thank you,

share|improve this question

1 Answer 1

You should run DNS on your Domain Controllers and host an Active Directory Integrated DNS zone for your AD there. This should be automatically configured after running dcpromo and opting to install the DNS Server role (I assume that you already are doing this. It's a basic step to setting up AD).

Then, your Windows clients should be configured to use your internal DNS servers for DNS resolution.

You can set this a few ways. The best way is to configure your internal DHCP server to tell your DHCP clients to use the internal server(s). This can be configured by setting DHCP Option 6 to the IP address(es) of your Domain Controller(s). Please, don't use a hosts file entry for this

If you still wish to use your external resolver for external DNS lookups, just set a global forwarder from your internal AD DNS servers to your external DNS resolver. At no time should your internal domain-joined workstations use any DNS server other than the ones that host your Active Directory zones.

share|improve this answer
    
Where can I get more information on setting up global forwarder? –  vkuzin Jul 19 '12 at 2:31
    
Well, google is your friend. I'd search something like "set global forwarder microsoft dns server" After you've done that and read the relevant documentation, if you're still having problems configuring that, you can always ask another question here. –  MDMarra Jul 19 '12 at 2:33
3  
+1 for "Please, don't use a hosts file entry for this." I actually saw that this week (and man did it cause some hard-to-troubleshoot issues), which just about made my head explode. Fortunately, the last admin didn't leave a forwarding address, so I'm not in jail. >:/ –  HopelessN00b Jul 19 '12 at 2:59
    
"The best way is to configure your internal DHCP server to tell your DHCP clients to use the internal server(s)." But I don't have DHCP role installed on this server. I was using DHCP on the router. Is that bad idea? What to do in that case? –  Vladimir Kuzin Jul 19 '12 at 4:58
    
If you must you the crappy DHCP server on your router, configure it to hand out your AD DNS servers. –  MDMarra Jul 19 '12 at 10:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.