Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm writing my own little file upload CMS in php for my website.

The problem I'm having is that whenever I upload anything over 13MB or so the upload reaches 100% then instantly greets me with an internal server error page, and the file is not uploaded. Other than that the file uploading works completely perfectly.

For reference, I changed all of these php ini settings and it still doesn't work:

max_execution_time = 1200     
max_input_time = 1200   
memory_limit = 120M      
max_file_uploads =120MB  
upload_max_filesize = 120M
post_max_size = 130M

and the code I'm using to store my files is after they've been posted is:

move_uploaded_file($_FILES["upload"]["tmp_name"], $_SERVER['DOCUMENT_ROOT']."/download/".$name);

Also my website's running on a virtual server provided by fatcow.

Thanks in advance for any help.

share|improve this question

migrated from stackoverflow.com Jul 19 '12 at 3:19

This question came from our site for professional and enthusiast programmers.

    
Did you restart the server after making the changes? –  j08691 Jul 13 '12 at 3:03
    
Are you able to see the server's error log? It should help a lot. –  Ariel Jul 13 '12 at 3:04
    
Seeing as its shared hosting, I'm not able to restart the server, maybe I should take it up with the hosting provider though. –  Tristan Jul 13 '12 at 3:14
    
Alright I found my error log, but there's abolutely nothing recent, only errors pertaining to different directories and different problems I had in the past ): –  Tristan Jul 13 '12 at 3:19
    
Alright, I'm off to bed. If there are no super dandy answers by tomorrow I'll start down the treacherous path of fatcow user support. Thanks again. –  Tristan Jul 13 '12 at 3:27

2 Answers 2

Well, I got an answer, but its not a good one.

Apparently, although it says nowhere on their site, the max file upload size on their server is 10MB, no matter what you change in the php ini or otherwise. I had to go through live chat and all that jazz to learn this, and it sucks.

So a word to the wise, if you want decently sized user upload, don't host with fatcow.

share|improve this answer
    
That is a pretty common limit for any shared hosting. If you need to upload larger files you'll need to go with a desicated server or a vps. –  Zypher Jul 19 '12 at 3:54

I have seen this issue when PHP is running as a fcgid handler. If you have changed the settings in php.ini and restarted the server to no avail, you need to set FcgidMaxRequestLen in your http.conf.

The value is in bytes. I would just set it to a large enough value to accomodate the largest POST value you are expecting:

#Max request size of 13 megabytes
FcgidMaxRequestLen 13631488
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.