Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just got myself a new VPS, not the first I can assure you.

Upon adding any DNS entry, I am prompted with this:

WARNING: key file (/etc/rndc.key) exists, but using default configuration file (/etc/rndc.conf)
rndc: connect failed: 127.0.0.1#953: connection refused

I have no idea how this problem started, and I've tried the cPanel fixrdnc script with no success.

What's the trick to get this warning to go away?

share|improve this question
add comment

1 Answer

If it is CentOS6 then you can just delete rndc.key and restart named. That fixed similar issue I had some time ago.

share|improve this answer
    
Nope, Didn't work. Still getting the same error. –  Moe Jul 19 '12 at 7:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.