Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use VPN to access the servers at work. When VPN is used, all network traffic to the Internet passes through my company network. It worked without any problems on Windows 7, now on Windows 8 some sites suddenly became inaccessible. Please note - I don't try to connect them over RDP, they are public Internet addresses, outside company network.

They are inaccessible using any protocol. Ping returns "General failure.".

I know it could be a misconfiguration on my company's server side, but it's very strange, since the same VPN connection used on Windows 7 works properly.

What's wrong? Is it a Windows 8 bug, or is there something I could do on my company servers to make VPN work as expected with Windows 8? My company network works on Windows Server 2008 R2 and uses Microsoft TMG firewall. I couldn't find any rules blocking the traffic to mentioned sites, all network traffic for VPN users are passed through for all IPs and protocols.

Any clues?

UDPATE: Important - one whole day it worked. I hibernated and restarted the computer, connected and disconnected VPN - nothing could break my connection. Today it broke again, and restarting Windows didn't help. And now the solution:

route add -p 0.0.0.0 MASK 255.255.255.255 192.168.1.1

Oh, OK, I know what it did, added my default gateway to routing table. But it still didn't work sometimes. So I removed my main network gateway route with:

route delete -p 0.0.0.0 MASK 0.0.0.0 192.168.0.1

And added modified with:

route add -p 0.0.0.0 MASK 255.255.255.255 192.168.0.1

And it works. Now. But I don't trust this. I don't know what really happened.

share|improve this question
4  
File a bug report with MS. Win8 hasn't been published yet. –  SvW Jul 19 '12 at 12:24
    
So you CAN connect to ALL hosts which are "inside"? And just not to "SOME" hosts on the internet? or does NO host work on the internet? –  MichelZ Jul 19 '12 at 12:29
    
Try enabling split tunneling –  resmon6 Jul 19 '12 at 20:35
    
Yes, hosts inside work. Some of the outside ones don't work. For example - google worked, some other site in France didn't. The behavior was also very random. Sometimes it all worked, and then stopped to work. I'll try to file a bug then. I don't think it's the server fault :) It doesn't block any traffic from VPN to Internet, AFAIK. Now I mostly use Win7 again, because I need Internet access at work and I can't disconnect VPN every 5 minutes. –  Harry Jul 20 '12 at 17:42
add comment

2 Answers

up vote 2 down vote accepted

On the VPN Connection properties:

-> Networking -> Internet Protocol Version 4 -> Advanced... -> Unceck "Use default gateway on remote network"

This ensures that you are NOT using the VPN's default gateway, but your local one. (You add it manually with the route add command)

share|improve this answer
    
Thanks! It seems to work now, and the main connection is not marked as "Limited" anymore. Should I remove my changes to routes now? –  Harry Jul 24 '12 at 13:09
    
Windows 8 does not appear to have "Use default gateway on remote network" option –  tutuDajuju Jun 22 '13 at 6:18
    
It does. It's exactly the same –  MichelZ Jun 23 '13 at 14:12
add comment

All is not right, you just need to set the metric 5000 in vpn connection setting and after all will work. Checked!

It placed -> Networking -> Internet Protocol Version 4 -> Advanced... -> Unceck "Auto set metric" and write in field below 5000.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.