Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Usually when I setup a new Ubuntu VM, i keep the eth0 in NAT mode to get the internet & I add a eth1 interface in HostOnly mode so that I can ssh.

But using this devStack guide : Running a Cloud in a VM, it looks like it tried to use eth0 as the public interface (install got stuck because eth0 lost the network).

I know an OpenStack setup usually requires two NICs, so I'm wondering what is the correct configuration for my VM.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

I started with the guide Experimenting with OpenStack Essex on Ubuntu 12.04 LTS under VirtualBox and here are the settings I wound up with in VirtualBox

Under Preferences > Network create a Host-only network called vboxnet0.

vboxnet0 (disable DHCP Server too)

vboxnet0

Create a new VM and go to the Network section.

The Adapters for the VM itself. Adapter 1 Adapter 2

Network settings in the Ubuntu VM /etc/network/interfaces

auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

#Public Interface
auto eth1
iface eth1 inet static
address 172.16.0.1
netmask 255.255.0.0
network 172.16.0.0
broadcast 172.16.255.255

And in my devstack localrc file I've included the two settings.

FLAT_INTERFACE=br100
PUBLIC_INTERFACE=eth1

Hope this works for you too!

Everett

share|improve this answer
    
Is this answer still correct? Devstack local.conf doesn't seem to have these options anymore. –  SHC Jan 30 at 13:54
add comment

If you have vagrant installed along with virtualbox, you can start devstack using vagrant-devstack:

$ git clone git@github.com:dolph/vagrant-devstack.git
$ cd vagrant-devstack
$ vagrant up

Networking configuration is handled by the included Vagrantfile.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.